Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have setup three alarms on my HTC Desire (running standard 2.1 with Sense).

  1. Mo, Tu, We, Fr @ 05:45
  2. Th @ 05:30
  3. Sa @ 07:00

They are set as repeating alarms and the phone displays the little clock symbol in the top right corner indicating that an alarm is active.

I have been running the phone with DeskClock activated each night and this also says that there is an alarm active for 05:45 the next morning. However I have watched it (with it not working for some strange and bizarre reason I am waking up before the alarm goes off) and at the time the alarm is set for nothing happens.

Can anyone shed some light on this? My wife has a HTC Hero that is also running 2.1 and her's appears to be working correctly.

I also have ATK that is running and is set to auto-kill running applications and I have been wondering if this is the cause, however this does not kill the DeskClock app that is running so I am not sure if it is relevant.

share|improve this question
    
mine doesn't work when the phone is off... and now I am also using LiveHome on my android and the alarm doesn't work at all!!! –  zany Jan 8 '11 at 2:15
    
I take it back! I have started using Live home on sunday and my alarm isn't set on sundays..... all week days but sundays so I mixed things up a bit –  zany Jan 8 '11 at 2:16
add comment

3 Answers 3

When you set the alarm, select the alarm sound that you like best, at the same time activate the volume control. I had a similar problem with my HTC Hero before I realised that the volume control had someohow been set to its minimum. I must stress that the volume must be activated whilst selecting the required sound. Hope this helps.

share|improve this answer
add comment

I had lots of problems with this myself, as you suggest my taskkiller was closing it down, on changing an alarm setting it would start back up. You should be able to press and hold on a task in advanced task killer and tell it to ignore the alarm task. This seems to have done the trick for me anyway.

share|improve this answer
    
Cookey, Just tested this by setting up a new alarm, then ATK'ing the Clock app and the alarm didn't go off. I then setup a new alarm and this time 'ignored' the Clock app in ATK and sure enough this time it worked fine. Thanks for your help. –  TravisPUK Jul 22 '10 at 15:32
add comment

You are certainly not the only one with alarm issues. Check out this list of defects related to the alarm on the issue tracker for Android OS. Unfortunately it seems like the symptoms vary depending on a lot of factors or do not seem to be consistent at a glance.

The symptoms you described for the HTC Desire running 2.1 are EXACTLY what I experience. Funny thing is... I have an HTC Hero running 2.1 (same as your wife's)! I can also tell you that the alarm used to work on my HTC Hero before upgrading from 1.5 to Eclair.

I do have a workaround that worked in my case that you might want to try:

I found that the alarm was not going off if the phone is not plugged into a charger. Once I started leaving it on the charger at night it works 100% of the time for me. If this doesn't work for you, or perhaps you already leave it on the charger and it still doesn't work, I would suggest doing some research on the issue tracker. If nothing there seems to help maybe enter a new issue to bring it to the Android team's attention.

share|improve this answer
    
@Saul, thanks for the reply. I always have my charger in at night so I don't think this is the problem. I also assume that this is more to do with HTC Sense than Android itself, but could be wrong on this. –  TravisPUK Jul 22 '10 at 15:26
    
@TravisPUK, your best bet as a starting point would still be the issue tracker. I'd trust the Android team to be more responsive to feedback than HTC or anyone else involved. They may be able to help you narrow it down a bit even if it's not something in the OS causing the problem. –  Saul Dolgin Jul 22 '10 at 15:29
    
@Saul, see above ATK was definitely the culprit in this little failure. Thanks for your input though. –  TravisPUK Jul 22 '10 at 15:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.