Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I receive calls and alarms go off, the phone vibrates. However it won't vibrate for any notifications.

Changing the vibrate setting from vibrate always or vibrate only when in silent mode has no effect.

Does anyone know what can cause this and how to fix it? Is there a separate hidden setting for notification vibrations?

For what it is worth I'm running a HTC Magic with a custom 2.3-Gingerbread ROM installed. This definitely used to work. Not sure what I did to break it though.

Update: I've got it working again by playing with the settings.

Under Settings->Sound settings->Volume 'Use incoming call volume for notifications' was ticked.

When I un-ticked this setting the notification vibration began to work again. This seems really strange to me and if anyone could help me understand what is going on it would be much appreciated.

Update 2: Installed an app called AudioManager. It has separate vibrate checkboxes for alerts and ringer. Using this helped too. Not 100% but it seems to indicate separate settings that are not exposed through the regular settings interface.

share|improve this question
Did this work before and stopped, or have you never had vibration working? What phone do you have? Are you using a custom ROM (and if so, which)? – Matthew Read Mar 15 '11 at 3:45
I've updated the question to include this info. – sickgemini Mar 15 '11 at 4:00
The AudioManager suggestion was awesome -- I had the exact same issue and this also solved it for me. You should add it as the accepted answer to this question. – Michael Nov 7 '11 at 21:09
@Miquel Ok. Done! – sickgemini Nov 7 '11 at 23:12
up vote 3 down vote accepted

Install an app called AudioManager. It has separate vibrate checkboxes for alerts and ringer. Setting the checkbox for alerts fixed the issue for me.

share|improve this answer
Is there an open-source app that has the same functionality? – landroni Mar 12 '14 at 10:10

You can have app-specific notification settings. Have you gone into the settings of the offending apps to see whether they're set to vibrate on notifications?

share|improve this answer
Thanks but I have. GMail, Mail, Calendar, Messaging, all set up to vibrate but no vibration. – sickgemini Mar 15 '11 at 3:38
OK, I've asked some questions up above to help us troubleshoot further. – Matthew Read Mar 15 '11 at 3:45
Hmm. Well a factory reset should fix it but hopefully we can find something easier. – Matthew Read Mar 15 '11 at 4:31
Even better ... get new phone! (Have to convince my wife first) – sickgemini Mar 15 '11 at 5:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.