Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I'm using an LGP500 Android Phone (Android 2.2). In the default SMS application, when I select a discussion, I see the previous SMS (both sent and received), and there's a text area at the bottom of the screen to write a new message.

For most of my contacts, this behavior is working correctly, but for a few of them (which I use quite often), the text area is not shown. Those contact have a mobile phone number, and I can send SMS using the long way (create a new sms, search the contact ...).

Does anybody have an idea of the cause or the solution ?

Edit I tried a few things to fix this : clearing the data, deleting any previous sms history, changing the phone number from the local (06xxxxxxxx) to international (+336xxxxxxxx) format (french phone numbers), changing the mobile phone number as default phone for the contact, in vain.

share|improve this question
    
Is their number formatted differently from your other contacts? –  Matthew Read Mar 16 '11 at 14:35
    
Does the problem exist if you use a SMS app replacement such as Handcent? –  Bryan Denny Mar 16 '11 at 15:24
    
Nope... Some contacts use the classic french format (06########), some others use the international format (+336########). I already tried to switch the number format, but in any case some contacts have the text area, others don't. –  XGouchet Mar 16 '11 at 15:26
    
It's working correctly with Handcent, but I want to use the default SMS app if possible. –  XGouchet Mar 16 '11 at 15:45
1  
Is there anything different about these contacts? Stored on the SIM, perhaps? Or their phone number is not marked as "Mobile"? –  Al E. Jun 23 '11 at 16:01

6 Answers 6

up vote 1 down vote accepted
+50

This is a problem i face with few contacts on my P500 too! Try merging contacts with their FB account or twitter account or just create a Buffer account and join them. It works after that. Not a great solution but been working that way now!

share|improve this answer

I don't know why this is happening but you may be able to fix it by clearing the data from your messaging app. From the home screen you go to settings > Applications > Manage Applications then choose the Messaging app (or whatever your sms app is called). If the option to clear the cache is there try that first but most likely you'll have to choose to "Clear Data". I believe this will delete all the messages you have saved so keep this in mind.

share|improve this answer
    
This is not working, in fact event after clearing data, I still see my messages. I guess they are stored in another application or service but I don't know which one. –  XGouchet Mar 23 '11 at 7:48
    
How about deleting and re-adding the contact? –  Matt Mar 23 '11 at 12:00

My experience with this has been with non-mobile type numbers. If you happen to have multiple numbers for a contact, and for some reason it happens to select the Home or Work number rather than the Mobile, it will disallow you to send text messages to these numbers. Have you checked to make sure the number you're sending it to is classified as mobile?

share|improve this answer
    
Yyes the phone number I send to is classified as mobile (I also made it the default number for thosr contacts). –  XGouchet Jun 24 '11 at 4:32

It may because the Messaging app "Only Mobile Numbers" setting enabled, try to disable it. On Messaging App:

Menu > Settings > Extra Settings > Only Mobile Numbers
share|improve this answer
1  
I do not have this extra settings in the sms app settings. –  XGouchet Jun 24 '11 at 4:33

Are you absolutely sure you are using the stock messaging app of android 2.2? (maybe you could be using a modified version by your manufacturer which may be buggy). Anyways try the following (which is for froyo's default messaging app)

  • Go to Text Message Settings > "Manage SIM card messages" (check if any messages are there and try to move it back from it).
  • Go to your conversation, Long press the "menu options" softkey on your android to get the keyboards and start typing to see if the field pops back.
share|improve this answer
    
I don't know if the manufacturer changed something but it looks a lot like the stock app. I tried what you suggested, there was no sms ln the sim card at all, and a long press on the menu button does not make pop up the soft keyboard on my phone. –  XGouchet Jun 24 '11 at 4:28

Perhaps some contact information got corrupted. Try re-syncing the contacts on the phone.

Menu -> Settings -> Applications -> Manage applications -> All, scroll down to "Contacts" app and tap on it, select "Clear data". Do the same for the "Contacts Storage" app. This should clear all contacts data. Now go to Menu -> Settings -> Accounts & sync, go into every account you have and toggle the "Sync Contacts" option off and back on. This should force an immediate re-sync.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.