Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a corporate sync account set up to sync my work calendar, contacts and email. I had some trouble setting it up, but once I got it set up it worked just fine for a couple of months. Then about a week ago it stopped sending emails. I can still receive emails. Also, the internet still works on the phone. Gmail still works. Sending and receiving calls and texts still works. But when I send an email it gets stuck in the outbox.

I have tried removing the corporate sync account and adding it back. I have tried restarting the phone multiple times and doing a manual refresh each time. I have tried various combinations of security settings (Use secure connection and Verify Certificate). Nothing helps.

I can't believe no one has asked this yet! Based on the forum posts I have read, it seems like a common problem. Is there some solution waiting in the wings?

[Droid 2 w/ Froyo]

share|improve this question
up vote 2 down vote accepted

The first thing I'd suspect is that a database used by the Email app is corrupted. To fix this, you need to go to Settings -> Applications -> Manage applications, find the Email app, and clear the data for it. (If you see anything like "Email Storage" be sure to clear the data for that as well). Then re-add your account and see if that helps.

If that doesn't work, I recommend asking your company's IT department if they have changed any settings for the Exchange server recently.

share|improve this answer
Indeed the IT department had changed the settings. – Stainsor Mar 29 '12 at 19:27

I was seeing the same problem items get stacked in the outbox when you either aren't connected to WIFI or don't have cell coverage. Once you have access to a WIFI network the outbox will not empty out or sync either on its own or by going to settings and accounts and synching all.

All I did was compose a new message and sent it -- and all of the messages in the outbox seem to follow. ;-) Sounds too simple to work, but try it.

share|improve this answer

Weird, I had this problem, tried to send a message with no signal and when I got signal back, I kept getting "unable to send mail". I moved the messages to another folder and re-sent them and they went. Looks like a bug with the client.

share|improve this answer

Probably you are using Exchange 2003, though there are some reports these things happen also with Exchange 2007.

Try to edit the messages stuck in the outbox and remove the check from the checkbox "Include quoted text". It will then send your message.

In the future, when you answer messages, choose the option "respond inline", and then it won't happen.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.