Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a HTC Desire HD running stock 2.2

When using the HTC supplied headphones, the play/pause/nav controls only work with Meridian. I don't remember explicitly setting it up as such, although I may have missed it. I'd like to be able to use them with BeyondPod instead, as I'm about 10x more likely to be listening to a podcast than music.

Is there a way to change the default app for these buttons?

share|improve this question
    
Similar problem but with different music apps android.stackexchange.com/questions/5994/… are there any similar options in Meridian? –  GAThrawn Mar 21 '11 at 11:56
    
So I had this page open on another tab for ages before I saw I hadn't saved the comment. Probably would've been more helpful before you found the answer yourself! –  GAThrawn Mar 21 '11 at 11:58

1 Answer 1

up vote 2 down vote accepted

A bit more playing around led me to a (if not THE) solution. I found an "enable headset buttons" check box in Meridian, which prompted me to dig further into BeyondPod, where a found a similar setting.

Everything works as I'd like now.

I've since gone back and checked a couple of things though, which are not quite as I expected. I thought if you re-enabled the controls within one app, it might disable the other. This isn't quite what happened. When I re-enabled Meridian, it responded to the controls, although BeyondPod still showed it as supposedly responding, which it didn't. Once I'd disabled Meridian again, I had to go back into BeyondPod, disable and re-enable it's control in order to have it respond again.

My main gripe was that if I were listening a podcast, and bumped the headphone controls, the music would start playing over the top of my podcast audio. While it may be a cute multi-tasking demo, it's not a particularly practical use of this feature, IMH(BC)O.

share|improve this answer
    
To clarify: You disabled Meridian from receiving headset actions, and enabled BeyondPod. And you're now using your headset to only control BeyondPod, not both Meridian and BeyondPod? –  Ilari Kajaste Sep 19 '11 at 8:33
    
Yes, that's correct. –  John T Nov 28 '11 at 11:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.