Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I read a text and go to respond, for some reason there is 1/2 of a text that I sent a long time ago still in the reply text box and I have to erase it every time. How can I fix this?

share|improve this question
ok... i punched my phone and now it went away... but im trying to figure out how to use other ways than violence to solve my problems so i still need help for the future. Thank you – user3811 Mar 26 '11 at 4:14
What the hell are you talking about? What "text" are you referring to? What "box"? – Lie Ryan Mar 26 '11 at 6:04
@Lie Ryan "a text" is a common synonym for an SMS message. The "box" would be the entry field. – Chris Stratton May 18 '11 at 15:51

Since you mentioned text-messages my guess is that maybe you have a draft that the messaging app wants you to finish, although with my HTC Evo it doesn't do what yours is doing. Try opening the message app and on the screen where you can see "All Messages" open the menu and you might see an option to select "Drafts" (looks like a old 3.5" floppy). If you have any drafts delete them and see if this fixes your issue.

share|improve this answer

Had this problem for the past couple days, and finally was sick of it. This morning, I tried deleting all my SMS messages. After that didn't work, I did this: Menu - Settings - Applications - Manage Applications - All - Messages, then hit "Clear Data". That resolved the issue. You can try doing this before deleting your SMS messages, but it may delete them when you clear the data -- not 100% sure (it does warn it will wipe them). problem solved!

share|improve this answer

Menu - Settings - Applications - Manage Applications - All - Messages -> Clear Data worked for my HTC Thunderbolt.

share|improve this answer

I have the same problem sometimes with my Thunderbolt too. I deleted all the drafts and it does nothing, but you are on track because mine have been text that I typed in before either by mistake or never finished. Here is the problem.

The way I cleared it out before was to create an entirely new conversation since it is limited for a particular person, in my case.

share|improve this answer

On the main messages screen open the menu, then select drafts->menu->delete drafts.

Select the messages you want deleted, then press delete.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.