Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I'm trying to connect Nexus 4 (Android 4.4.4) to Windows Server 2012 R2 DataCenter for purpose of debugging from Xamarin Studio.

What I did:

  1. Activated Developer Settings
  2. Checked USB Debugging
  3. Installed Google USB driver from Android SDK Manager

But Windows doesn't see it when I connect by USB cable.

Maybe it isn't possible with Windows Server?

PS. But it's charging and I see connected as MTP in USB computer connection.

UPDATE: I tried to connected it to Windows 7 and it's working. But I still have problem with Windows Server 2012 R2.

So question is: should I change some settings in Windows Server 2012 R2 or it is not available to connect Nexus 4 at all to Windows Server?

share|improve this question
    
Does the phone think it's connected? You get a "USB Debugging connected" notification with a picture of a KitKat if it does. –  Dan Hulme Jul 10 at 8:34
    
no, I don't see any notification. –  Alex Jul 10 at 11:43
    
Do you have the SDK Tools installed? Install adb by running tools/android and selecting the latest platform tools and then try running adb devices in the platform-tools directory –  keepcalm Jul 10 at 11:50
    
I have Android SDK Manager. Is it what you mean? –  Alex Jul 10 at 11:56
    
@Alex The notification for USB debugging shows up regardless of whether ADB is running or connected on the host PC, so my first suggestion is to double-check that USB debugging is enabled on the phone. In particular, note that the on/off switch at the top of Developer Options doesn't turn on USB debugging: you need to check the check box labelled "USB debugging". –  Dan Hulme Jul 10 at 11:58

1 Answer 1

Try updating the driver in Device Manager.

share|improve this answer
    
Google USB Driver Revision 10. How I can update it? –  Alex Jul 25 at 0:27
    
Your device would be listed in Device Manager (either in Other Devices section or in Android Device section). Right click on that and choose the Uninstall option. Once uninstalled, re-connect your device and choose manual installation of the driver (Browse my computer for driver software) and choose the path for Google USB Driver ("path to ADT-Bundle"\ADT-Bundle\sdk\extras\google\usb_driver). This should solve the issue you are facing. –  VikramV Jul 25 at 4:18
    
I don't see Other Devices or Android Device sections in Android SDK Manager. –  Alex Jul 26 at 1:16
    
okay, Device Manager, not Android Manager. –  Alex Jul 26 at 17:21
    
okay, updated driver in Device Manager, it looks okay there, but still don't see phone in Windows. –  Alex Jul 26 at 17:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.