Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

When I'm on the phone, my cheek will often push buttons on the screen, causing either the call to end, or unintended navigation. This is really annoying - I try my best to keep my face away from the phone but I'm not always successful.

Am I the only person having this problem? Is there an actual solution?

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

On my Droid there's actually a proximity sensor that disables the screen if anything is too close to it. On the Droid this sensor is up next to the ear speaker so that when you put the phone up to your ear it triggers the proximity sensor.

What model phone do you have?

share|improve this answer
1  
For what it's worth, I also have a Droid, and sometimes the proximity sensor doesn't quite work. It's entirely possible that I'm holding the phone in a way they didn't anticipate, or I just have a funny head. –  Al E. Mar 28 '11 at 17:45
    
I have an HTC Aria. –  Marcel D. Lamothe Mar 28 '11 at 17:55
1  
@Marcel Lamothe - The Wikipedia page for your phone lists a proximity sensor as a hardware input, so I'd try to find out why that isn't working. It might be set to a sensitivity that you aren't triggering if you don't put it right against your head. –  JonnyP Mar 28 '11 at 17:59
1  
Yep, just tried it out - now that I know the phone has a proximity sensor (didn't even occur to me before) and where it is (in the top right corner), I had no problems at all - thanks! –  Marcel D. Lamothe Mar 28 '11 at 18:22
add comment

On my phone I can click the power button to turn off the screen, so no buttons are there to be pressed.

share|improve this answer
    
Nice, just gave it a try and it worked like a champ, thanks! –  Marcel D. Lamothe Mar 28 '11 at 16:39
2  
On my phone the power button is the end call button. –  Amanda Mar 28 '11 at 17:01
    
@amanda this is a setting in the accessibility menu: imgur.com/8VggX –  thunsaker Mar 29 '11 at 0:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.