Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to send a text message - attaching a photo already on my phone ( the first time ) and attaching a picture taken at time of send ( the second time ).

However, when I try to send this text message - the status remains sending ( an my correspondent does not receive the message ).

Is this a problem with my phone company, you think, or can I have changed some setting somehow. Is there a setting that can be set, anyhow ?

I did send picture attachments with text message before , some weeks ago , but not after upgrading to Froyo 2.2.1 ( just to be complete - can't think this has anything to do with it ).

------------- [ UPDATE ]-------------------------

Something I noticed but did not mention before : if I view a text message with a picture attached, and press the image to 'view' it,*a sort of movie view is started*e.g. with the picture at the top of the screen, and a Start, Rewind and Forward button at the bottom. Pressing the Start will 'play' the picture as move of about 5 seconds - since it is a picture, of course the image does not change. I am pretty sure this was not the case when I sent some image messages a couple of weeks ago. To be complete: even the image messages I did send before now show this 'movie' type of action.

share|improve this question
Regarding your update: This is normal behaviour, at least on my Galaxy S this has been happening ever since 2.1-update1. – onik Apr 12 '11 at 13:22
up vote 10 down vote accepted

In case this helps someone with the same problem, I have the solution :

I had to check the Settings - Wireless and network - Mobile network - Use packet data check box. When this was done, I could send picture MMS messages.

Maybe obvious for some .. but it sure was one setting I thought I should not need just to send an MMS message.

share|improve this answer

You could check your MMS APN settings, they can be found in Settings -> Wireless and network -> Mobile networks -> Access point names. There should be some reference to MMS settings and it should have your operator's MMS settings. Also, check out the settings found in Messaging -> Menu button -> Settings -> Multimedia message (MMS) settings -> Creation mode. Verify these and try again :)

share|improve this answer
nope, all these settings seem to be set as I would expect them to be set. Strange. Gonna try and reboot the phone. You never know, do you ? – Edelcom Mar 29 '11 at 12:52

I assume you have a Belgian carrier? Some sites you can check for MMS settings:

share|improve this answer
settings are correct ( at least they are the same as in the link you provided - I have Proximus as Belgian carrier ). Thanks for the link. But still no luck ... – Edelcom Apr 6 '11 at 4:07
just tried the power down - wait 10 seconds ( as the guy in the Proximus thread gives as solution ), but that doesn't solve the problem. Will try and phone the support from Proximus ( that will be a laugh ) ! – Edelcom Apr 6 '11 at 4:22

I had a similar problem in the UK with Orange after I rooted my phone. Settings all looked correct. Deleting the two APN profiles that were there and re entering them by hand following instructions on a page similar to those provided by @Matthew Read fixed it.

I urge you to try deleting and re-entering the APN's by hand.

share|improve this answer
did that, didn't help. See my own answer ( the accepted one, where I found the solution ). – Edelcom Apr 8 '11 at 16:11
APologies, didn't notice your own answer, or that it was accepted (why is it not at top of thread?) – fearoffours Apr 8 '11 at 16:46
ordered by votes ? You could help here :) – Edelcom Apr 8 '11 at 16:48

I've had a similar problem, APNs 'appeared' correct, company phone so the liaison guy reported the issue to telco (O2), settings needed sending over the air to fix, and something their end.

...had to wait a few hours for the settings to be received but MMS etc did start working.

share|improve this answer

If you have troubles sending text message- attaching a photo, go to Settings > applications > Manage applications, select tap All, press "Messaging" and finaly press Clear data. Your "use packet data" must to be activated.

share|improve this answer

Is simple, after you press play you need to press menu > attached and finaly save, You can see the picture in Gallery.

share|improve this answer

I had to select Settings --> Wireless and Network --> Mobile network settings and under network operators I had to search and then choose my provider that came up in the list.

share|improve this answer

I had the same problem. Photo messages just said «sending» but never went. Solved problem by enabling packet data and turning on 3G. WiFi wouldn't work.
Once I switched to mobile-data, photos were sent instantly.

share|improve this answer

protected by eldarerathis Jul 11 '13 at 16:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.