Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Android Phone (a Motorola Milestone) and trying to connect it to my Ubuntu Maverick (10.10). The problem is that i can't even charge it using USB, so there's no message on the phone nor on the computer that a device has been connected.

I also have a Laptop running Ubuntu Maverick aswell and there I can access the phone via USB.

I already created the 51-android.rules file with the according settings, but it didn't work. And I guess this rules-file doesnt matter in this case, because my laptop doesn't event have this file.

Other USB devices like external hard drives can be used as usual, the USB cable itself can't be the problem, because I can use it on my laptop and it works.

I really don't know what the problem could be.

It is also not listet in lsusb on my computer.

Did anybody have a similar problem?

Thank you in advance for any help!

share|improve this question
Are you sure other USB-powered devices work? Have you tried a different USB port? – Matthew Read Mar 29 '11 at 15:26
I did try all other USB ports. I even just unplugged my external hard-drive (which i was listening music from) and plugged in my phone. But no reaction at all :( – user3922 Mar 29 '11 at 15:28
@Robert That's quite bizarre. I'm guessing the power output from the port is low, although I would think the hard drive wouldn't work either. I don't think we're going to be able to help you (though I'd love to be proved wrong). If you happen to have a bigger power supply laying around, try it :P. @Al He addressed that in the question. – Matthew Read Mar 29 '11 at 15:32
well my external hard drive has it's own power supply, so it's possible that it's a power issue. I'll try a hard drive without an external power supply and report back. Thanks for the hint! – user3922 Mar 29 '11 at 15:36
OK, I'll post that comment as an answer and we'll see how it fares. – Matthew Read Apr 1 '11 at 15:40

I'm guessing the power output from the port is low, although I would think the hard drive wouldn't work either. You could try connecting your phone to a powered USB hub, and connected the hub to the computer. Or if you have a desktop, it could be a power supply problem, in which case you could try one with a higher wattage.

share|improve this answer

In my experience the udev rules are only required for fastboot and this shouldn't be related to charging.

share|improve this answer
To be more precise: They are also relevant for ADB (USB-debugging). But you are 100% correct: They are not relevant for charging. – Izzy Mar 23 '13 at 14:48

Endless hours were spent trying to connect my Motorola Razr to my computer. This finally worked:

Go to Google Playstore on the phone. Download Motorola PIM (all upper case). If you have an extended battery case/charger on the phone, remove the phone and insert the USB cable into the port on the top of the phone.


Download “AirDroid” and connect wirelessly.

Hope this helps someone!

share|improve this answer

Not a fix, but a work around. My tablet wont appear on my Unbuntu laptop if I use USB 3. It DOES work if I either use a USB 2 port, or a USB 2.0 micro cable, forcing the tablet to use USB 2.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.