Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Moto G running Android 4.4.4. I am trying to connect to a Wi-Fi network with an accented character in the name. The network's name is 'Sala de Reuniões', but it appears to the device as:

enter image description here

Note that the 'õ' became an 'unknown character'. As a result the device doesn't connect, but a PC can connect to the same network. I can't change the network name as the router is not mine.

What to do?

share|improve this question

2 Answers 2

up vote 1 down vote accepted
+100

Have you tried installing Portugese* as a language in your phone settings? Your current language obviously does not contain that character. If you download and install the Portugese* language pack for your phone, it should recognize that character in the Wi-Fi network name.

Alternately, you could try to manually add the Wi-Fi network to your phone using the network SSID. Simply type in the correct SSID (network name) with the special character instead of trying to auto-detect the network.

EDIT:

As a quick and dirty solution, you could also use an app like WiFi Connection Manager which claims to be able to handle special characters.

Also, according to this page (http://unix.stackexchange.com/questions/39352/unable-to-connect-to-a-wifi-network-with-a-special-ssid), it seems like the default Android encoding of SSID's is the source of your problem. The only fix I've seen is using an app or writing your own driver or script to connect to the network using the correct encoding for special characters.

share|improve this answer
    
My language (Portuguese) has the 'õ' character, changing it (tried to English and Spanish) doesn't help; and adding the network name manually doesn't work, either. –  Renan Jul 28 at 13:36
    
What kind of error did you get when you tried manually entering the network name? (Also, sorry about the language mix up :O) –  pheidlauf Jul 28 at 13:43
    
I get no error: it just doesn't connect. –  Renan Jul 28 at 13:52
    
It seems like this error happens on Android most everywhere there is a special character in a network SSID. Take a look at the edits in my answer. –  pheidlauf Jul 28 at 13:54
    
WiFi Connection Manager seems to work, will try it for a while. Accepting the answer and will give you the bounty if all works correctly. –  Renan Jul 28 at 14:17

Try installing an app for connecting to SSID having special characters in it. You may find it in the Android Market.

Or you can download it here.

Reference - Stackoverflow link.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.