Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Yesterday, I installed Froyo on my iPhone 3G with iPhoDroid. I'm trying to connect to the WiFi using MyWi on my jailbroken iPhone 4 but the network isn't visible at all. The network is WEP secured. That's not a problem with Android is it? I see lots of unsecured networks around, but I'm at work and they're all through proxies anyway, so that wouldn't work. Anyone have any insight on this? I'm completely new to Android so this is exciting to me!

share|improve this question
    
Hi Thomas, I removed the salutations because the first line of the question appears in the summary pages. –  Rich Seller Aug 4 '10 at 14:37
    
ahhh...thanks I never realized that lol. –  Thomas Aug 4 '10 at 14:53
add comment

1 Answer 1

Have you checked whether the network is broadcasting its SSID? If it isn't then your phone won't find it and the network won't appear in the list. You can enter the network details manually by going into the Wi-Fi settings (under Wireless and network on my 2.1 phone), then clicking Add Wi-Fi network (at the bottom of the Wi-Fi networks section), then entering the network's SSID.

If you're already doing this and the network isn't being added, it may be that the router has restricted the client devices that can connect to it. In this case you'll have to use a client with an established connection and modify the settings to allow your phone. You can typically add the MAC address to a whitelist. You can typically find your phone's MAC address under Settings->About phone->Status->Wi-Fi MAC address

share|improve this answer
    
Thanks for the help Rich. I did try manually entering the SSID. That didn't work. And as far as editing the router's white list, the MyWi doesn't have that option (as far as I can tell). I tried disabling security on my network, and it still wouldn't recognize it. –  Thomas Aug 4 '10 at 17:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.