Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I've a Samsung Galaxy S with 2.2 firmware. I'm using handcent instead of the default messaging application. In the default messaging app settings I have disabled notifications and disabled auto-retrieve. But when I get an SMS now, even after I had read it in handcent, I still get the new message notification overlay on the messaging icon on the homescreen until I click into it. Can i disable this, or better yet replace that icon with handcent?

share|improve this question

2 Answers 2

up vote 8 down vote accepted

Assuming you are using the default Samsung TouchWiz launcher:

  1. Open the App Drawer (Applications)
  2. Press Menu, select View Type -> Customizable Grid
  3. Press Menu, choose Edit
  4. Drag off the Messaging icon, and drag on Handcent.

I've replaced it with Gmail, myself.

share|improve this answer
1  
exactly what I needed, I didn't know those dock icons were customizable in this way. –  Alb Apr 10 '11 at 0:32

What home screen application are you using? In Launcher Pro, I can long-press on the dock icon, and change the icon and/or shortcut. I can also disable the overlay from Menu > Preferences > Dock Settings > Missed call count/Unread SMS count/Unread Gmail count

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.