Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I'm using Samsung Galaxy Ace GT-S5830. More than an hour ago, Samsung-Kies prompted me to install a firmware update. It downloaded the required files and then proceeded to the actual upgrade. Now, since an hour, I'm getting 0% progress on the "Firware update in progress..." screen. It obviously says not to disconnect the phone. The phone shows "Downloading..." It's been like this since an hour. I don't want to brick my phone by pulling the USB cable off. Please suggest something.

share|improve this question

migrated from superuser.com Apr 11 '11 at 20:12

This question came from our site for computer enthusiasts and power users.

1 Answer 1

I would suggest pulling it off and trying again. Usually this happens when Kies wasn't able to properly communicate with the device after putting it into Download Mode. I've had this happen before and rebooting my device and trying again worked. You can also try putting the phone into Download Mode manually (may or may not work while plugged into USB):

  1. Remove the battery
  2. Hold VolumeDown plus the Home key plus Power. While holding,
    1. Reinsert the battery.
    2. Release the Power button, still holding the others, about 1 second after the white logo text appears.
    3. After a few seconds a yellow triangle with an android in it should appear, this is Download Mode. If it doesn't, try this again while holding Power the whole time.
share|improve this answer
    
Thanks, Mat! Pulled it off and the phone started normally. Will try it again tomorrow, gotta go. –  user4292 Apr 11 '11 at 20:33
    
@Karan Did this work for you? –  Matthew Read Sep 9 '11 at 16:58
    
It works for me. –  krocan Nov 25 '11 at 14:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.