Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Nexus One, and since upgrading to 2.3.3, my phone lasts several hours less compared to 2.2.x. I've swapped out to a new battery, which didn't make a difference. In about 14 hours (of nothing more than texting), my phone is at less than 15%. When I check the Battery use under Settings, Android OS is always the top battery consumer.

What can I do about this? Every other update besides this one has been great, but Gingerbread is a total disappointment.

Update: This is 100% an issue with wifi. After disabling it, the battery usage of Android OS has dropped from 40% to 2%. After 16 hours on battery, it's still more than half charged. I'll keep investigating...or revert, because I think Gingerbread just looks fugly.

share|improve this question
    
FWIW, Gingerbread has also cut my Nexus One battery life (now about 2/3 of what it used to be). Be thankful you even get 14 hours. After my 8 hour day of mostly idle, I go to my phone to discover it has already shutdown. –  Andy Shinn Apr 12 '11 at 1:48
    
That's 14 hours without doing anything ... The keyboard also freezes / crashes a lot. All around terrible update. –  wsanville Apr 12 '11 at 1:57
    
Unfortunately, I'd have to agree. Are you running the stock update or a 3rd party packaged one? I was having phone reboot issues running a 3rd party ROM. Stock is more stable. But both had poor battery life. –  Andy Shinn Apr 12 '11 at 2:11
    
I installed this right from the phone, it said there was an update available, so I just did it. It wasn't from a 3rd party. –  wsanville Apr 12 '11 at 4:02
    
Same phone, same build, same problem. In fact, my phone sometimes runs hot! Battery consumption shows a huge amount of CPU being consumed by Android OS, sometimes, 3-4 hours out of 12hours. –  bosporus Apr 12 '11 at 9:37

4 Answers 4

Revert? If the OS itself is not sleeping properly, you can't do much else besides install a kernel or ROM that behaves better.

share|improve this answer
    
I would have to root my phone to do so, correct? –  wsanville Apr 12 '11 at 22:18
    
I don't think so? Maybe to prevent an OTA update afterwards. You should be able to just download an update, name it update.zip, put it in the root of your SD card, and reboot. The 2.2.2 update is linked here for example: androidcentral.com/… –  Matthew Read Apr 12 '11 at 22:57
    
Alright, and if I want to go back to 2.3.3 (for some strange reason), I just do the same thing with the corresponding zip file? –  wsanville Apr 13 '11 at 12:19
    
Yep, exactly that. –  Matthew Read Apr 13 '11 at 12:57
up vote 5 down vote accepted

As of 2.3.4 this issue is fixed. For other users on previous versions, I temporarily solved this problem by disabling Wifi all together.

share|improve this answer

If it is a Wi-Fi issue, have the stand by settings changed with the new installation?

Settings->Wireless & Networks->Wi-Fi settings

Menu->Advanced->Wi-Fi sleep policy

Has this setting changed from to Never (Which will keep the Wi-Fi on all the time)?

share|improve this answer
    
Thanks for posting how to get to the Wifi sleep policy, I read about that all over the place, but couldn't find it. It's currently set to "Never when plugged in." What I've read suggests there's a bug with the sleep policy, where it malfunctions when trying to sleep and conserve battery, but instead, drains it like crazy. So changing this to "Never" has helped some people. What would you recommend setting it to? I've just disabled wifi entirely, and that helps the battery last longer. –  wsanville Apr 19 '11 at 12:30
    
I'm in a different situation where I pay per MB for mobile data so I set Wi-Fi to never sleep. –  sickgemini Apr 19 '11 at 12:34

Have you tried updating the battery statistics? It is said to help with battery life in some cases.

  1. Charge the phone completely.
  2. While still on the charger, boot into recovery.
  3. In recovery, reset the battery statistics.
  4. Reboot the phone.
  5. When it has booted completely, unplug the charger.
  6. Run the phone until the battery is completely flat and the phone turns off.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.