Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

This question is similar to Mount disks from Samsung Galaxy S i9000 to Linux System over USB cable but I want to get it to work on my stock T-Mobile G2. The G2 does not have any USB configuration in Settings>>About Phone.

On the same machine running Windows XP, when connecting the phone via USB, I can see it mounted and made available as disk E:.

I have gone into Settings>>Wireless & Network Settings>>Tethering & Portable Hotspot and enabled "USB tethering" while connected, and I got the "Turn On USB Storage" option.

The phone is charging while connected to Linux, so I know there is some handshake between the host and the device.

share|improve this question
    
It seems to be Debian-specific. I have connected my phone to a Ubuntu host and it behaves as expected (the 'enable usb storage' button shows up). –  florin Apr 22 '11 at 21:32
add comment

1 Answer

When I connect my Samsung Spica to my Gentoo laptop, I get this in dmesg:

[380540.638713] usb 1-3: new high speed USB device using ehci_hcd and address 2
[380540.763249] usb 1-3: config 1 has 1 interface, different from the descriptor's value: 3
[380540.763258] usb 1-3: config 1 has no interface number 0
[380540.763745] usb 1-3: New USB device found, idVendor=04e8, idProduct=681d
[380540.763759] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[380540.763769] usb 1-3: Product: GT-I5700
[380540.763775] usb 1-3: Manufacturer: Samsung Electronics
[380540.763782] usb 1-3: SerialNumber: 57000da3e1f8
[380540.770454] scsi55 : usb-storage 1-3:1.2
[380541.771209] scsi 55:0:0:0: Direct-Access     GT-I5700  - Card               PQ: 0 ANSI: 2
[380541.773123] sd 55:0:0:0: Attached scsi generic sg2 type 0
[380541.778920] sd 55:0:0:0: [sdb] Attached SCSI removable disk

After enabling USB Mass Storage in the phone (the phone should prompt you on the notification bar), I get this messages:

[380708.007194] sd 55:0:0:0: [sdb] 1982464 512-byte logical blocks: (1.01 GB/968 MiB)
[380708.026714] sd 55:0:0:0: [sdb] Assuming drive cache: write through
[380708.029668] sd 55:0:0:0: [sdb] Assuming drive cache: write through

At any rate, these messages pointed me out which device file I should mount to mount the phone, in my case the device file is sdb, I simply create the /mnt/spica/ directory and do mount /dev/sdb/ /mnt/spica/.

Note though, if you used Gnome and the gnome's auto mount is set up correctly (i.e. it should just work out of the box, unless you disable it), then this all should be automatic. When I'm on Gnome environment, Gnome will usually prompt me to mount the phone on /media/ and the phone should show up on Computer like any regular USB stick.

The phone is charging while connected to Linux, so I know there is some handshake between the host and the device.

The phone can charge on any powered USB port, it does not need to do any handshake for charging.

share|improve this answer
    
It only does that if I am in the 'usb tethering' menu. If the phone is locked and I connect it to a Linux host, it does nothing. If it is locked and I connect it to a Windows host, it beeps and on unlock it prompts to enable USB storage mode. –  florin Apr 20 '11 at 21:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.