Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Hi
I have a problem with my Wifi connection. My Samsung Galaxy S does not connect to my Linksys wrt54g router after I'm disabling the SSID broadcast.

The connection is automatically returned when I enable the SSID Broadcast.
Why is it like that and how can I fix it?
Thanks.

share|improve this question
    
Possible duplicate: android.stackexchange.com/questions/2782/… –  Daniel Apr 17 '11 at 3:53

2 Answers 2

This is because Android by default (manufactures could of added something ) connect using only the SSID, not the BSSID.

See this issue : http://code.google.com/p/android/issues/detail?id=1041

This app here might help: https://market.android.com/details?id=jp.sourceforge.soopy.hidden.ssid.enabler&feature=search_result

This is the design to connect by SSID instead of BSSID for mesh networks, this becomes helpful.

Also if your router and phone support WPS button, try that.

share|improve this answer

Disabling the SSID broadcast doesn't provide any meaningful security to your wireless network. The days that it might help make your network harder to spot are long, long past.

As such the best "fix" is to re-enable the SSID broadcast.

share|improve this answer
    
This is right, not displaying the SSID does not help at all, you still show up to every computer. WPA is the only working security for WiFi. (WPA-AES has better OS support) –  Seth Hikari Apr 18 '11 at 19:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.