Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

In the stock messaging app, the contact I'm messaging has their picture next to their replies, but mine is just a grey box; how do I get my picture there? I have a contact called 'me' with my picture and phone number, but it's not making the link.

I'm running Gingerbread 2.3.4 on Nexus S.

share|improve this question
add comment

9 Answers 9

Assuming the answer to my comment above is Talk, you need to change your picture in your Google Account. This is most easily done through Gmail's settings on a PC.

If you sync your contacts from Gmail, that picture might possibly show up in your SMS app as well.

share|improve this answer
add comment

I stumbled across getting my picture to show in a very weird way. First of all I use Gtalk and my phone is connected to my gmail and my gmail happens to be firstname.lastname@gmail.com which I have a picture for. So I went into contacts clicked add new contact. For first name I put in only my first name and filled nothing else out then I hit the button that brings up the settings on my phone and there was a join option. When I hit join option it gave me suggested contacts which i'm assuming recognized my first name and pulled up gmail account to join and I saw myself show up with my gmail picture voila!

share|improve this answer
add comment

I created a contact with my name, full telephone #, and email and added the photo to my contact. My photo now shows up in txt messages and in gmail app. I have no clue if it will work with other email and sms apps.

share|improve this answer
add comment

I am facing the problem as well on 2.2.3. I have gone through different suggestions and from them it seems that the owner's phone number needs to be in the SIM itself. The original post is here : http://forum.xda-developers.com/showthread.php?t=687011 .

I could not try it myself since I am yet to find a phone where I can assign my number to self.

share|improve this answer
    
Hmm that sucks you can't do this in Android, is there an app which can do this? –  Dunhamzzz May 5 '11 at 8:03
    
Yes, there is one such app, but I could not recall the name of it. Also it didn't install on my device. Not sure whether that will work for you or not. But if you want, you may try at android market. –  Arindom May 5 '11 at 8:06
    
App doesn't work on Nexus S :( –  Dunhamzzz May 24 '11 at 12:54
add comment

I had the same problem, I was very frustrated with all the postings that kept directing me to facebook! Not all of us want to be that connected... Anyway I kept at it on my own and this is what worked for me:

  • Go into your text message history
  • Tap on your "shadow" figure
  • Tap on your menu icon at the bottom of your phone
  • Tap on "Edit"
  • Tap on your "shadow" figure
  • Tap on "Gallery"
  • Tap on photo from your gallery
  • Save

Jeez couldn't believe how long this took me to work out, it's not in the manual that comes with the phone in fact almost nothing is in the manual I have had to find just about everything I needed through forums such as this. That being said after it's all figured out I am ultimately happy with the HTC Wildfire S.

Thanks to all of you who took the time to help us out.

Good luck! :-)

share|improve this answer
    
Can't tap the blank picture on my phone, doesn't do anything :( –  Dunhamzzz Nov 22 '11 at 13:10
    
it wouldnt let me click on the grey box is there another way?? –  user10466 Dec 10 '11 at 8:34
add comment

Mine was similar to, but not exactly like, Kimmy's above:

  • sms history / view a specific conversation.
  • tap gray image. phone wanted to add a new contact.
  • tap menu button.
  • select insert image - select image from gallery.
  • select OK - I never did assign the contact a name, phone number, or email address.

Now all my sms messages show the image I just assigned.

Note - I already had my own contact with an image, which was sync'd to gmail, but for some reason the sms app wasn't picking it up.

HTC Droid Incredible

Hope this helps somebody out there...

share|improve this answer
1  
Note: referencing another answer with "above" or "below" makes no sense, because answers can be sorted in a number of ways. –  Al E. Jan 6 '12 at 1:38
add comment

This worked for me (CM71 firmware):

For users of CyanogenMod-6 go to Settings -> Call Settings -> Additional Settings -> My phone number. Have a try, this should solve you all problems.

Source: http://code.google.com/p/android/issues/detail?id=8519

share|improve this answer
add comment

Turns out that if you log into the Google+ app, then your local account ("Me") will be synced with your profile account (Google contacts).

So just download the google+ app (if you don't have it aldready) and log on to it should solve the problem.

I am using Android 4.0 by the way.

share|improve this answer
add comment

If you get the error Toast message "The contact does not exist" when you click on your gray profile image (in the Messaging app), then do this:

  1. Open the "Contacts" app (it has a blue icon that looks like a stack of cards)
  2. It should list all your contacts, with an entry "Me" at the top, with a gray icon
  3. Click on the gray icon at the top, in the section "Me"
  4. Add a photo from the Gallery or from an installed file browser app.
  5. This photo will now show in the Messaging app.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.