Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a google acount set up, and i had lots of contacts in my address book that got synchronized with the ones in my phone address book.

I've found out that i can organize my contacts into groups, and then make those groups "not sync" with my phone, but i have no way of un-selecting the group named "other contacts", basically thats the group where all unassigned or recent contacts go. That is very annoying.

How can i make my phone not fill up my phone agenda with my email contacts? Is there any other sollution other than deleting the contacts from my "other contacts" every day?

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted
+50

My Motorola Droid 2 (VZW) has a similar problem. My contacts menu has a "Display group" option. This shows several options:

  • Create a new group
  • All contacts
  • Favorites
  • User created groups
  • Facebook contacts
  • Google contacts
  • Phone contacts

As you can see there is no way to specify Google contacts that aren't "other contacts" except to create my own groups. Unfortunately whatever group I show does NOT become the default group that shows every time I open contacts.

I have decided to solve the problem just by using workarounds.

  • For the couple people I call the most I have widgets on the home screen to call that specific person. (Long press home screen -> Motorola widgets -> Contact quick tasks)
  • For the next tier of people (I will call them more than once in a while) I just use favorites. Either Long press home screen -> Shortcuts -> Dialer -> Favorites ... or just hit the call button and choose the favorites tab.
  • When I have to resort to the full contacts listing I just start typing the person's name and that narrows the list to a manageable size.
share|improve this answer
    
not the answer i was hoping for, but it does the trick... –  Quamis May 16 '11 at 6:29
    
I feel your pain. It definitely feels like settling. –  Stainsor May 16 '11 at 13:41
add comment

I'm not sure how this works on Morotola Defy (Moto is known to replace the stock apps with their own versions), but in standard Android installation (2.1 and above) you can pick which groups are displayed in the Dialer/Contacts apps. Launch the Contacts app, then go to Menu -> Display Options. Under the "Choose contacts to display" section, expand your Google account and you should be able to un-check any group, which will hide its contacts.

share|improve this answer
    
i have done that. On my defy, its under Contacts->Show/Hide-> and there i have the possibility to hide the google groups, bu i have no way of hiding the "other contacts" group. At this point, i've checked all checkboxes and everything should be hidden, but its not... the "other contacts" group is still visible. –  Quamis May 6 '11 at 14:31
    
It's important to note that "Other Contacts" isn't actually a group. It's all the contacts that don't have a group, and they are only grouped together for display purposes on the website. –  Matthew Read May 10 '11 at 2:23
    
@Matthew: yes, you're right, but i still dont want to have them displayed in my agenda. I'd rather have my Family group be displayed that "Other contacts".. –  Quamis May 10 '11 at 9:40
add comment

How can i make my phone not fill up my phone agenda with my email contacts?

You can set it to only display contacts with phone numbers if that helps.

In the contacts app, check the option: Menu->Display Options->Only contacts with phones

share|improve this answer
    
Can you merge this with your other answer and delete this? –  Matthew Read May 10 '11 at 2:24
    
I've deleted the other one as there was already a similar answer above. (Need to read better!) I thought the two answers were different though so that's why I submitted twice. Is that bad form? –  sickgemini May 10 '11 at 6:14
    
I dont have that option in my menu... i saw this solution on the web, but it ain't available on the defy i guess... –  Quamis May 10 '11 at 9:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.