Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I'm using a Nexus One on T-Mobile in the US. A couple months ago my OS was updated to Android 2.3. Since then I've had a weird problem with my calendar events.

I can view calendar events just fine, and the calendar syncs with my Google Account bi-directionally without issue.

When I create a calendar event, the "time zone" option defaults to my current time zone, "GMT -4, Eastern Standard Time", just like it did on Android 2.2. However, when I touch the time zone option to select a time zone, there are two time zone entries that match mine. One is "GMT -4, Eastern Standard Time", the other is "GMT -4, Eastern Time".

The problem happens when I edit an event. Frequently, when I edit a calendar entry, the event jumps 4 hours ahead unless I manually edit it back down. For example, if I create a calendar event and set the starting time to 1:00pm, when I edit the event I've created the edit screen will show a starting time of 5:00pm. It still shows the correct time zone, but it adds the 4 hour GMT difference into the event's starting time. If I save the event without adjusting it back down, the next time I edit it it will say 9:00pm. This happens regardless of whether the event was originally created on the phone, or if it was created on my desktop PC by visiting http://www.google.com/calendar. It doesn't seem to matter which of the two "US Eastern Time" options I select when creating an event on the phone. This problem did not exist before I installed Android 2.3. It doesn't happen with every single event, but I haven't been able to figure out what the common element is between the unaffected events. It does seem that events that are freshly-created are less prone to this problem (possibly the problem starts after the data's been synced a few times?)

If I create a calendar event on my phone, and then edit it on my desktop PC using http://www.google.com/calendar, the PC edit screen behaves normally, and the changes sync back to my phone without issue. Only when editing events on the phone do I experience this problem.

It's very annoying that I have to dial my events back 4 hours every time I make a change to them. I've experimented with different settings but I haven't been able to figure out how to make this go away. Does anybody know how I can fix this?

share|improve this question
add comment

4 Answers

up vote 2 down vote accepted

I had a problem with a secondary calendar which sounds similar. On edit the time zone changed. I went into the calendar and made sure all of them were set to my time zone. Each calendar has changeable time zone on Google calendars.

share|improve this answer
    
Thanks! I found that one of my three calendars had the GMT +0 timezone instead of my correct Eastern Time. I've changed it, and I'll watch it for a while to see that fixed it. –  Joshua Carmody Jul 7 '11 at 13:19
    
Yep! That was it. Fixing the time zone for the one calendar fixed the issue. I don't know how it got changed since it was apparently working right before, but thanks a lot for giving me the solution to this long-time annoyance! –  Joshua Carmody Jul 13 '11 at 19:28
add comment

I would suggest clearing the Calendar data and re-syncing the events from your Gmail account(s).

Go into Menu -> Settings -> Applications -> Manage applications -> All then scroll down to Calendar, tap on it, and tap on the "Clear Data" button. Do the same for the "Calendar Storage" app. Now go back twice (exit to the main Settings menu) and go into the Accounts & sync section. For each account you added, go in and toggle the "Sync Calendar" option off and then back on again.

After the calendar data finishes synchronizing, try editing an existing event again and see if the issue persists.

P.S. You might need to re-enable the visibility of one or more calendars in the Calendar app by going to Menu -> More -> Calendars and ensuring the ones you want are set as "synced, visible".

share|improve this answer
1  
Thanks for the suggestion. Just tried that, but unfortunately it didn't solve the problem. –  Joshua Carmody May 20 '11 at 13:37
add comment

I just figured out the fix and I'm no techie. After reading several of these posts I noticed someone said to uncheck a setting under calendars. I unchecked the box that said "use home time zone" after setting time to my zone. It worked even though I can't tell you why. I have only had my android for a week and have not traveled out of this time zone. I probably just checked the box not realizing what havoc it would cause!

share|improve this answer
add comment

Uncheckinge the "use home time zone" option also fixed it for me, although I am at a loss to know why this is so, especially since I didn't travel outside of home. Now, if I could only figure out how to keep google calendar and contacts in synch with MS Outlook, I'd be a happy camper.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.