Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When using the default browser on my Galaxy S, I can't see a cursor in text boxes that have focus. With no cursor I don't know where letters I type will appear. This seems to occur on all sites I have tested. Can someone with this phone confirm there is something wrong? Note that the address bar at the top is fine and behaves as I would expect.

Input method is the Samsung keyboard. No third party apps or firmware installed. Feel free to ask questions if you need more info. Thanks

share|improve this question
Can't reproduce on my T-Mobile Vibrant (I tried all three keyboards). – Niall C. Sep 7 '10 at 12:55

Press and hold the ?123 key at the bottom, left corner of the standard Samsung Galaxy S keyboard. The keyboard switches to a four arrow cursor pad that you can use to move around a text field. There's also a delete key, select, cut, copy, and paste; click the Text key to switch back into keyboard mode.

This works with just about all text fields in all applications that I use.

share|improve this answer
+1 I didn't know that ! Just received mhy Galaxy S last week and learning something new every day. This site certainly helps. – Edelcom Oct 5 '10 at 15:17
Great tip, Erik. And from the Swype keyboard you activate the arrow keys layout by swyping from the special "(i)" key, in the lower left, to the SYM key - SEE… from… – micahwittman Oct 29 '10 at 20:34
I'm happy to help! – Erik Westermann Nov 2 '10 at 2:02
I've had this phone for months, and had no idea it had arrow keys. LIFESAVER. – GWLlosa Nov 23 '10 at 15:07

Just tried on my Samsung Galaxy S with the search box at the top of this page in the built-in browser and I get a flashing cursor all the time I'm not typing (it disappears while I'm typing but comes back if I pause for a moment) I'm using the built-in Swype keyboard.

Also tried switching back to the Samsung Keyboard (by long-pressing on a text field, then selecting Input Method and selecting Samsung Keyboard) and still see a cursor in the search box on this web site.

My Galaxy's running the standard Samsung version of Android 2.1, pretty sure I don't have any apps installed that affect the keyboard or browser.

share|improve this answer

Try using a different browser. Also you could try going into settings, apllications, manage applications, find the browser you are using and clear data, if that option isn't there, try cache. Reboot and see what happens.

share|improve this answer
I switched the phone off and on again and the problem seems to have gone away for the moment. I keep an eye on it for a few days to see if it comes back. – James Sep 8 '10 at 8:24
Glad to hear things are back to normal. Most quirks are fixed by a reboot. I should of suggested that as option 1. – Webs Sep 8 '10 at 15:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.