Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have purchased a Motorola Defy some time ago, and imported my address book from my old featurephone using the SIM card.

Under Settings / Account now I have two accounts listed in the Motoblur section (the motoblur account and an email account), and one account listed under Other accounts (the gmail / google account).

Now I would like to sync all contacts to the google account, but it won't: it has synced only the new contacts I added, but the old contacts are in the telephone only. What is the correct way to sync contacts to the gmail account?

I am running official froyo firmware, french version.

share|improve this question
    
Sounds like the contacts are save either "To Phone" or "To SIM", they need to be "exported" and created as contacts on the gmail account. –  Ryan Conrad May 25 '11 at 15:52
    
I suppose there's no Google logo in the contact lists for these particular contacts ? I don't think Android syncs contacts that are stored on the phone. They need to be associated with a Google account. –  ddewaele May 25 '11 at 15:54
    
Yes I realized that they are not sync'd :) My question was indeet what to do, in order to have them exported to gmail. –  Palantir May 26 '11 at 8:54

1 Answer 1

up vote 1 down vote accepted

So it turns out that there is no other way than to do it manually, and it is not difficult at all :)

  1. Get MyPhoneExplorer (I am sure you can do it using the Phone Portal too, but MyPhoneExplorer is just SO convenient :)
  2. Go to the Contact tab, right click on any contact, click on Export/Import, Export all contacts, and select the csv format
  3. Check that the CSV file is OK opening it in Excel for example
  4. Open GMail, go to the Contacts link and click on Import, select the CSV file and import
  5. Now return to the phone explorer, and delete all your contacts
  6. Click on android's Settings - Accounts, click on the GMail account and click on synchronize contacts. All your contacts are restored to your phone, but now they are linked in GMail.
share|improve this answer
    
I'm glad you got it sorted. You should "accept" this answer so that future readers with a similar problem will know that this was the solution. –  Al E. Jul 8 '11 at 12:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.