Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have tried loads of ways to connect my phone to my PC (it used to work!). The PC will not even recognise the phone as a device anymore. I have also tried reinstalling the drivers via Samsung Kies. What is the solution?

share|improve this question
1  
Have you installed other USB drivers that might be conflicting with it? I had the same problem and eventually found it was caused by an old version of Microsoft ActiveSync. Once I removed ActiveSync, I was able to connect my Galaxy S again. –  Niall C. May 28 '11 at 13:55
1  
Try some other USB cables and ports as well. –  Matthew Read May 28 '11 at 15:58
1  
Just wanted to echo what @Matthew said. I've had experiences with bad USB cables. Also, Samsung Galaxy S phones have a somewhat recessed micro-USB connection, so you have to make sure that whatever cable you use really gets down in there. –  Chance Aug 15 '11 at 16:58

4 Answers 4

Remove the SD card and the SIM card. Restart the phone and only plug it in when its restarted completely. Make sure the phone is set to USB Kies. Check the cables too!

share|improve this answer

Try to uninstall the Galaxy S drivers from the Device Manager in Windows while it is plugged in, and then reconnect the phone to the computer.

share|improve this answer

I had this problem with Ubuntu and Windows. Just today after installing Dropbox ( which is a good workaround BTW) after the following steps, my phone was recognized as if it were a flash drive:

power off. connect USB to PC. charge for a while ( irrelevant I assume) power on while connected.

I don't know whether Dropbox changed some setting or permission, whether something else I played with did, or the power-off-on sequence fixed it.

share|improve this answer

Try to disable USB debugging. When you connect you will then have a button labelled "Connect USB" on the phone. Press it and it will install itself. It worked for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.