Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In the gmail app, I keep finding conversations that display multiple draft versions of replies that have long been deleted via the drafts folder. Is there a proper way to remove drafts from all conversations, or perhaps a settings available to fix? v2.2.1, Samsung Charge.

share|improve this question
    
Have you looked to see if they're still in the Drafts folder in the web interface? – Matthew Read May 30 '11 at 20:34
    
yes, they are not there. only on the droid. – matt ryan May 30 '11 at 20:48
    
once the account syncs again, the drafts will most likely disappear. – Ryan Conrad Jun 2 '11 at 20:31
    
If that were the case, I wouldn't have made this post. – matt ryan Jun 3 '11 at 0:52

The question is old but the issue is still very alive today. My mailbox in Gmail is a mess. After much digging I've found a solution in this web site. The post was the one from "Jim R", I'll post it in here. It's actually for people with Mail on OS X but just the part in Gmail should (hopefully) suffice.

Gmail (web site) side:

1) Quit Mail.app.
2) Log into Gmail in your favorite web browser.
3) Click on the gear menu and select “Settings”.
4) Click on the “Labels” tab.
5) Under “System Labels”, next to “Drafts”, click on “show if unread” and uncheck the “Show in IMAP’ box.

OS X side:

1) Launch Mail.app.
2) Select Mail > Preferences…
3) Click on the “Accounts” button in the toolbar.
4) Click once on the account name and then click the “Mailbox Behaviors” tab.
5) Uncheck the “Store draft messages on the server” box.
6) Close the window and opt to save your changes when prompted.

It worked for me on 2 accounts out of 3 (in Android Gmail). In one account the boxes in "5)" didn't show up in Gmail setting in the web site so the spam of drafts is still there.

UPDATE: I did some additional testing, and I've found out that at least in that account the drafts were stored in the trashcan in the Web interface. Now emptying the trashcan for good they finally disappeared from Android Gmail (they didn't show in OS X Mail anyway) and with the new OS X Mail settings it seems they do not get generated anymore.

share|improve this answer

I had this problem on a Galaxy Nexus with version 4.6 of the GMail app. Clearing the app's data via Settings > Storage > Apps > GMail > Clear Data forced GMail to reload all my messages, and when the troublesome threads reappeared, the drafts were gone.

share|improve this answer
    
For posterity: Clear Data clears your GMail notification (sound and vibration) settings too. There's a Clear Cache setting right below Clear Data that may solve the drafts problem without clearing notification settings; I didn't test that. – bar13 Nov 8 '13 at 19:04

Only way I found around it is to find the conversation in the normal gmail web interface, scroll all the way to the bottom where it says "n deleted messages in this conversation. View messages or delete forever." where n is a number and press "delete forever". Certainly not a satisfying solution.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.