3
votes
2answers
251 views

I Want to Download ann App That is Free and is for android 1.6, i have android 2.1 and it says its not compatible [duplicate]

Possible Duplicate: Why are some Apps on the market incompatible with my device? Thats it. I Wanna Download This App ...
6
votes
2answers
264 views

Upgrading developer phone

I've an HTC Magic Developer Phone running Android 1.6. I want to upgrade it to Android 2.1. Please guide me how to do this.