2
votes
1answer
152 views

Some 2.1/2.2 apps not working

I just upgraded my Galaxy gt i5800 to 2.2 froyo from the kies firmware. Why am I getting "not compatible with this device" from some apps that say they require 2.1 or 2.2? Can anyone please explain.