140 reputation
139
bio website neolisk.com
location Mississauga, Canada
age 26
visits member for 2 years, 3 months
seen Nov 8 at 23:04
  • MCSD: Web Applications (since 12/14/2013).
  • MCPD: Windows Developer .NET 3.5 (since 09/16/2012).
  • Specializing in anything VB.NET, experienced using .NET 4.0 WinForms & ADO.NET.
  • Researcher at heart, always looking for ways to improve.

profile for Neolisk on Stack Exchange, a network of free, community-driven Q&A sites


Oct
1
comment Remove bloatware on Galaxy S2 - what are my options?
Thanks, Izzy - you seem to be the only one hanging in here on android.stackexchange. I managed to remove all Samsung apps in question without rooting, so hopefully they will no longer bother me with updates. Some garbage apps needed "uninstall updates", for Disable button to appear, and some cannot be disabled at all, although I don't believe they are critical. Still, a good workaround - 100% safe and covered with warranty.
Aug
23
comment Battery life cut in half recently - DrReadUsbStatus issue?
Ok, so I uninstalled all recently installed applications, but the issue still persisted. I disabled Wifi and the estimated uptime went as high as 7 days. Enabled Wifi - down to 3 days again. Disabled wifi and kept like that for 2 days. Enabled wifi again - 5 days. Now I am getting 5-6 days stable, same as before. Weird, but the issue has been resolved [by itself] for now. Thanks, Izzy.
Aug
13
comment Battery life cut in half recently - DrReadUsbStatus issue?
Last time I paid 5$ for 30K of data (all of it was local, no roaming) - another reason to keep it disabled at all times. Regarding apps, I am planning to remove all of them that potentially can access the internet, and see if I still have a problem with wifi on, if it's gone, then re-install one-by-one and figure out. A bit of a hassle, but better than doing a hard reset. I think it could be one of the app's updates, cause I specifically removed all newer apps and there is still a problem. Wish they had these stats on wifi as well.
Aug
12
comment Battery life cut in half recently - DrReadUsbStatus issue?
Mobile data is disabled at all times.
Aug
12
comment Battery life cut in half recently - DrReadUsbStatus issue?
By total runtime I meant time since last charged + remaining estimate. First is approx. 1d now, second shows as 5d+, so total 6d+ - not bad. Enabling wifi causes it to drop to 3-4 days after 1-2 hours (when estimate is adjusted). BTW, ConnectivityService locks never happened since wifi was disabled (according to BetterBatteryStats). So really it must be something about wifi now. Developer of Battery monitor widget suggested I should research CONNECTION permissions and disable/freeze/remove apps that use it, then re-enable wifi and see if is still eating battery. I'll post an update soon.
Aug
12
comment Battery life cut in half recently - DrReadUsbStatus issue?
Another update - ConnectivityService count:1461, I disabled wifi and left it like that overnight, estimated total runtime increased to 5d+ according to Battery Monitor Widget. DataRouter errors still present. So actually it may be unrelated to battery life issues.
Aug
11
comment Battery life cut in half recently - DrReadUsbStatus issue?
Update for partial wakelocks - ConnectivityService count:722, seems to be happening quite often.
Aug
11
comment Battery life cut in half recently - DrReadUsbStatus issue?
Installed BetterBatteryStats - measuring "Other" since unplugged (since 7 h 10 m 22 s) - No Data Connection ratio 100%, no or unknown signal ratio 100%, wifi on 38.1%, wifi running 38%, everything else is less. Kernel wakelocks - no events catched. Partial wakelocks - ConnectivityService count:586, NetworkLocationLocator:89 - is it where the problem lies?
Aug
11
comment Battery life cut in half recently - DrReadUsbStatus issue?
It does not seem like any app is eating battery. I ran a recording in System Tuner, taking samples every 20 minutes for 24 hours; here is what it says: CPU utilization 19m 49s, Android System 8m 59s, Fancy Widgets 3m 49s, System Tuner Pro 1m 39s, System UI 1m 20s, Settings 55s, WidgetLocker 39s, everything else is less than that. Hard to explain, unless there is a hidden process, which it does not show. SystemPanel does not seem to add any useful information to that. Is there a way to repair Android installation somehow, so maybe it will fix this USB issue?