We’re rewarding the question askers & reputations are being recalculated! Read more.
3 improved formatting
source | link

So I'm facing this problem for a while now . What happens is that my phone reboots automatically sometimes and after the reboot I can't use my WiFi . The button is stuck at off enter image description here So:

screenshot

So after doing some research on this I wiped my data/misc/WiFi/data/misc/WiFi folder to fix it (Didn'tdidn't create a backup though  )  . So the problem got fixed but it came back again  . So I wiped again and it didn't work this time  . 

In order to restore the folder I copied the WPA_supplicant files in the folder manually  . But I don't know what permission to set it to . And even if I change the permissions it gets reverted back to 0660  . Also I don't know whether the the .conf.conf file is even compatible for my phone as I got that one from an XDA post  . enter image description here Can

Screenshot

Can anybody guide me how I can fix this ?

So I'm facing this problem for a while now . What happens is that my phone reboots automatically sometimes and after the reboot I can't use my WiFi . The button is stuck at off enter image description here So after doing some research on this I wiped my data/misc/WiFi folder to fix it (Didn't create a backup though  )  . So the problem got fixed but it came back again  . So I wiped again and it didn't work this time  . In order to restore the folder I copied the WPA_supplicant files in the folder manually  . But I don't know what permission to set it to . And even if I change the permissions it gets reverted back to 0660  . Also I don't know whether the the .conf file is even compatible for my phone as I got that one from an XDA post  . enter image description here Can anybody guide me how I can fix this ?

So I'm facing this problem for a while now . What happens is that my phone reboots automatically sometimes and after the reboot I can't use my WiFi . The button is stuck at off:

screenshot

So after doing some research on this I wiped my /data/misc/WiFi folder to fix it (didn't create a backup though). So the problem got fixed but it came back again. So I wiped again and it didn't work this time. 

In order to restore the folder I copied the WPA_supplicant files in the folder manually. But I don't know what permission to set it to . And even if I change the permissions it gets reverted back to 0660. Also I don't know whether the the .conf file is even compatible for my phone as I got that one from an XDA post.

Screenshot

Can anybody guide me how I can fix this ?

2 edited tags
| link
1
source | link

wpa_supplicant.conf permission

So I'm facing this problem for a while now . What happens is that my phone reboots automatically sometimes and after the reboot I can't use my WiFi . The button is stuck at off enter image description here So after doing some research on this I wiped my data/misc/WiFi folder to fix it (Didn't create a backup though ) . So the problem got fixed but it came back again . So I wiped again and it didn't work this time . In order to restore the folder I copied the WPA_supplicant files in the folder manually . But I don't know what permission to set it to . And even if I change the permissions it gets reverted back to 0660 . Also I don't know whether the the .conf file is even compatible for my phone as I got that one from an XDA post . enter image description here Can anybody guide me how I can fix this ?