After i updated my Moto G2 to lollipop, my mobile data is broken. I have the proper settings, i tried rebooting, nothing works. I read on some other thread that i should exchange SIM slots. I cannot do that because T-Mobile actually stuck a nano sim in SIM1 slot.

any suggestions? should i try factory reset?


Two things to try:

  1. You can fairly easily find sim card adapters on ebay or similar sites (or build one via online instructions). I'm using an ATT nano sim in a samsung micro sim slot with a adapter and it's quite slick.

If the sim isn't sitting in the slot just right because of all the extra room (and lots of jiggling as it travels with you), it may be causing your lack of data connection.

  1. Contact t-mobile and verify that you're using the correct APN settings for the device/OS combo.
  • From what I have read for other questions like this, it looks like an APN issue. – Ryan Conrad Feb 17 '15 at 23:59
  • Hello, My APN settings are fine. Also, I cannot pull the damn nano sim out of the SIM1 slot. I have a micro sim in SIM2. Data connection worked wine with this setup on KitKat but as soon as i updated to lollipop, data is gone. – Sorin Panduru Feb 18 '15 at 7:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.