I have looked through the site, and it doesn't seem this has been answered yet. Once a day, at some point I pull my phone out of my pocket and it refuses to wake (black screen only). It isn't off, because the power button does nothing. I have to remove the battery in order to reboot the phone. I have looked for an app to help me find the cause (i.e. Log Collector) but it doesn't help because this isn't as simple as an FC, I am unaware when it happens until I pull my phone out. Is there a way to debug/find the culprit?

My info: Samsung Galaxy Gio GT-S5660, Froyo, rooted Note: I am running SetCPU (no profiles) and Tasker, they are suspects but I haven't been able to get an app to give me a continuous log.

  • This needs some new tags, but I don't have enough reputation to create any :). Also, I thought setCPU might be the culprit if the phone refused to wake b/c of the minimum CPU speed being too low, but I am currently set at 245min/800max, so I don't think that is the issue. I suspect Tasker, but I have not way to find out for sure yet.
    – Mingo
    Commented Jun 3, 2011 at 4:00
  • I found this post: android.stackexchange.com/questions/4614/… but it doesn't address this issue in particular.
    – Mingo
    Commented Jun 3, 2011 at 4:00
  • I would definitely suspect the clockspeed modification. SetCPU has never played nice with my Samsung Galaxy S. Commented Jun 3, 2011 at 13:34
  • I bumped the minimum up to 320, and so far no problems. I'll stick with this for a while and see if it works.
    – Mingo
    Commented Jun 4, 2011 at 2:14
  • Is it possible that the device is overheating? It's coming out of your pocket, after all.
    – ale
    Commented Dec 2, 2011 at 2:58

3 Answers 3


I think I had the same problem recently. When I pressed the phone's power button to wake it up, the display would turn on, but stay completely blank. It happened multiple times a day for me and I got frustrated, so I tried three things and one of those seems to have fixed the problem. Knock on wood.

  1. I reformatted my external SD-Card.
  2. I removed almost all of my media files from the phone.
  3. I disabled JuiceDefender's CPU frequency scaling

My prime suspect was the SD-Card, because the problems started to occur, when I inserted it, but I cannot be sure.

  • You mention removing CPU scaling in Juice Defender...that makes me suspect it as the culprit, and the CPU scaling from setCPU on my phone as the culprit. I'm currently trying shutting down 1 thing at a time to try to find the answer, but it takes time since it doesn't always black screen on me.
    – Mingo
    Commented Jun 3, 2011 at 7:25
  • @Mingo I hope you will find the definitive answer :-) I was too impatient to try one solution at a time. BTW: my battery life increased after I disabled CPU scaling. Probably because the CPU can sleep more now.
    – bjoernz
    Commented Jun 3, 2011 at 7:34
  • 1
    As it turns out, this issue is a bug in the WiFi, causing it to randomly freeze up the phone, requiring a reboot. Shame on Samsung! I'm only un-accepting this answer so future Gio users don't get confused as to why this doesn't solve their problem. As this point, waiting on Samsung to update the fw and solve this, or for Cyanogenmod to notice and develop for the Gio.
    – Mingo
    Commented Aug 2, 2011 at 4:15

I had the same problem with my Gio and I found out that it's because i leave WiFi ON for a while without working with phone.
This is a bug in Android-2.2 Froyo and it's solved in 2.3 Gingerbread which has been released on December 6, 2010.


When I had this happen on my HTC G2, it ultimately turned out to be a hardware issue. If disabling the SetCPU doesn't fix it, then I'd check your warranty coverage and make sure to get a replacement before it expires.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .