I'm having problem with my Samsung Galaxy Note 8.0. When I connect it to a laptop/desktop computer it just won't acknowledge the connection. I just wanna transfer some files to my tablet. Before it was working till the charging problem came up. I had to open up my tablet and work up on the battery connection, now everytime I connect my charger I need to wait 3-4 hours for the charging to start. And now my tablet doesn't respond to USB cable connection, no respond at all. It should give the message "USB connection detected...". I've searched the web and a lot of people are having this problem but not really getting the ultimate solution to it. Some worked for some but most didn't. Please show us how to fix it. Thanks much in advance, and sorry If I sounded a bit frustrated because I am. :D

P.S I might change the port for my tablet, I saw a blog that says it could have been worn out.


I think you've hit the nail on the head.

It sounds like you have a faulty port/connection. If you fiddle around with the cable in the device does it connect/disconnect? Have you tried using other cables etc?

The part that concerns me is that you say it starts to work after 3-4 hours. If this is the case every time; it could be even stranger than purely a faulty connection.


Goto about phone tap build number seven times to unlock Developer Options go into their, scroll down to USB configuration and click on file transfer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.