0

This question already has an answer here:

I see the list of internet word searches every I go to google play. No matter what settings I use the words are still there. Show searches I made on the device. But only in google playstore. It could become embarrassing. I cleared data for all application I could find use history and cache cleaners. Nothing works.

marked as duplicate by bmdixon, Ryan Conrad, Chahk, RossC, Izzy Feb 24 '15 at 14:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

Follow this instructions listed here. On Android:

Tip: If you want to delete your recent searches under the search box, touch and hold the search you want to delete > OK. The search will be deleted from the Google app and your Web & App Activity.

Delete items one at a time

  1. Visit your Web & App Activity page.
  2. Check the box next to the items you want to remove.
  3. Touch Remove items at the top of the page.

Delete multiple

  1. Visit your Web & App Activity page.
  2. In the top right corner of the page, touch Options > Remove items.
  3. Choose the time period for which you want to delete your history. (To remove all items, select The beginning of time).
  4. Touch Remove.

Note: If you turned on the option to include history from Chrome and other apps in your Web & App Activity, visit the additional Web & App Activity page to see that information. If you only want to remove additional Web & App Activity from a certain device, choose that device in the "Remove items" dropdown menu.

Not the answer you're looking for? Browse other questions tagged or ask your own question.