I bought a Sandisk 32GB Ultra OTG pen-drive yesterday and it was working fine, as in would allow me to both read/write through my Moto G(2nd Gen).

Last night, I plugged it into my Samsung Galaxy note Gt N7000, just to check if it can read files too and it could read/write without batting an eye. Today when I tried to move a video file to the OTG storage using my Moto, it would give me an error saying "the following items have not been pasted". Basically, I am unable to write anything to my OTG using the Moto G. It works fine with the GTn7000 though. I cannot understand what might be causing the problem.

I tried formatting the OTG to FAT32 with default allocation size and that too was unable to solve the problem.

Click to enlarge

  • I've got the same problem with the same usb stick you use. I'm running CM12 on a galaxy s4
    – Thomas Vos
    Feb 23, 2015 at 17:58
  • The best explanation I could gather was that Lollipop, like Kitkat has some permission related issues. It won't allow 3rd party apps like file managers installed from the play store to write on external sd card 2(usb). If you have a rooted device you could maybe eliminate this issue by adding a line of code to platform.xml
    – Weezy
    Feb 26, 2015 at 14:14
  • What should i add? (I am rooted)
    – Thomas Vos
    Feb 26, 2015 at 14:19

3 Answers 3


On lollipop, the 3rd party apps need to support the Storage Access Framework to write to external sdcards or OTG drives.

The apps need to be updated to support Storage Access Framework, the app developers need to be informed.

And considering the question old, many apps should have got updated by now. And the screenshot posted by you explains that the file manager is com.rhmsoft.fm which I'm sure is updated to support this feature as of now.

And through modifying the platform.xml, used to work in kitkat, but is not guarenteed on lollipop. There are reports that it doesn't work on lollipop.


I have faced same issue, please use the internal file manager instead of this. It works fine there.

  • Can you mention the device name and Android version you used to test this answer? It is possible that the inbuilt file manager (a system app) has appropriate permissions to write the OTG USB drive (an external storage), the reason why it solved the issue for you.
    – Firelord
    Feb 16, 2016 at 9:37

I too had the same issue with my MotoG 2nd gen. Was unable to write anything ... just solved it without any root or supporting application (Using ES file explorer i dont know if it will work with any other file manager. Never tried).

U just need to make a new folder inside your usb drive and customize its properties to hidden. (I did this from my windows PC)

And just write anything u want into that folder, u can access hidden folder from ur phone. Can later access those in ur PC by changing settings to show hidden files.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .