0

I'm trying too root my Asus memo pad 7 (170C), I've tried EVERY method, using KingoRoot, SuperOneClick, Frameroot, motochopper. None of them worked.

So I decided to do the rooting stuff myself, first I tried on Windows 8, the fastboot driver was not recognized, I installed the PdaNet, It recognizes the device now, the problem is when I run "fastboot oem unlock" or "fastboot oem unlock0x0b05" (ASUS VendorID), it returns : "FAILED (remote: unknown OEM command)"

I enter bootloader with "adb reboot bootloader" or by pressing Volume Up and Power.

I have also tried in Ubuntu 14.04, It doesn't even recognize the device in fastboot, and yes I run fastboot as root, still no chance :-( "fastboot devices" returns nothing, and "fastboot oem unlock" returns "Waiting for device"

I did run "usbls" command, and it was clear that the OS has recognized the tablet, but why the fastboot does not?

Here is some information of my specs: ASUS MemoPad 7 (170C) Windows 8.1 64bit AND/OR Ubuntu 14.04

Bootloader: DroidBoot Provision Os, DroidBoot Ver: WW_MeMO_Pad-11.2.3.28-20141230 IFWI Version: 64.25

PLEASE somebody save my life as I'm stuck with it for a very long time!

1

Ok, I searched for it a lot, tried everything and here is the final solution:

The propper rooting tool for ASUS tablets that use a x86 processor is "RootZenFone", the old fashioned way "fastboot oem unlock" and replacing the the recovery with something else DOES NOT WORK (As the time being).

If you have bricked your tablet (as I did!) you can perform a full recovery by following the instructions in this page. (Remember to install the USB drivers, provided in the same page)

If you are encountering the "Unfortunately Asus Demo has stopped" over and over again (even after a full ROM recovery), you need to run the RootZenFone (I tried version RootZenFone-1.4.6r.apk and it worked) after a fresh ROM recovery (using the link I provided above).

And it's really important to remember to "Forget each WiFi network" And "Disable the WiFi". If you are getting "Unfortunately Asus Demo has stopped" error, you NEED to disconnect the USB cable before you proceed to root the device using RootZenFone.

Just follow the instructions and you are good to go :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.