10

I am getting 2 notifications for the same email, both from the Gmail app. One notification is for the Inbox and the other is for a custom Label.

I do not want two notifications for the same email, so how do I prevent an Inbox notification if a label notification is triggered?

If I disable the Inbox notification, I will not be notified when a new email arrives. If I disable the Label notification, I will not hear the sound that is set to that label.

A couple more things to note...
- Some suggest moving the label emails away from the Inbox will solve it, which is true, but I need the label emails to show in my Inbox because I need to action them.
- I have the Inbox sound notification disabled because it clashes with the label notification sound (separate issue, but same cause).

Using Gmail v5.0.1 on Galaxy Note 4. Thanks.

  • Yeah, this is a major annoyance and renders the label notification feature essentially useless unless you label ALL your mail. We simply need an option that prevents two notifications for the same email. – Alex P. Miller Aug 28 '15 at 4:07
4

Gmail > Settings > select account with labels > Manage Labels > Select each label and uncheck "label notifications" that way the only notification you get is when it gets to the inbox, not a double notification for inbox AND the label

3

The way I fixed this was to check the box for "Skip the Inbox (Archive it)" when I made the filter and label with the custom sound. That way the message is only in one place and therefore only one sound is played.

Hope this helps. =)

1
  • Open the Gmail App
  • Go to the settings for the account tied to Inbox
  • Uncheck Notification

enter image description here

If this solution does not work for what you want to accomplish, there really isn't anything I, or anyone, can tell you to do. Inbox and Gmail are 2 apps for the same service. They are not meant to be used at the same time for the same account. In fact, when you first start up Inbox, it tells you to go in to Gmail and disable the notification.

  • 1
    Thank you for taking the time to respond. I don't use the Inbox app. I was referring to the inbox of the Gmail app. Sorry for the confusion. Any ideas on what I can do now this is clarified? – Rick Feb 26 '15 at 2:37
0

I used to have the same problem. One day I got a prompt from inbox asking me if I want to disable duplicate notifications. When I said yes, the notifications from the Gmail app stopped coming. Now it is only from inbox that notifies me. Don't know how to trigger that.

0

Go to inbox>settings> choose your account>there is a setting that tells you to stop getting notifications from Gmail. Also if you use it for a while it will make a prompt with the same question.

0

You can go to gmail - Settings- again - your account- then go to inbox sound & vibrate - in check Label notification.

Sunil

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.