0

I setup google 2-step authentication through Google Apps.

I linked my Skype number by Voice instead of SMS. SMS wasn't going through. It's a US number.

I'm trying to login on my Android phone in Thailand. I bought the phone in Thailand with a Thai sim. I set the Android language to English.

2-step is calling me and giving the number in Thai. I don't speak Thai.

There's no obvious setting to change the language of "Google sign-in" app on the phone.

I looked in the Domain Admin app and didn't see a setting to change the language. It's pretty frustrating.

Any suggestions?

Thanks!

  • I looked on Wikipedia to translate just the numbers out of the call. Not so hard. – Michael Cole Mar 4 '15 at 4:54
1

Did you took a copy of Backup Codes which are provided while enabling 2-Step Verification? They can help you to login if you've them.

Otherwise, try resetting your password. That's the only option left. And, from the next time install the Google Authenticator App from PlayStore as it creates code by itself and comes very handy. No reliance on SMS/Call.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.