1

I've attached an external drive to my phone using a USB-OTG cable. I can open it in File Manager (v2.0.0), but when I go to /storage/usbdisk none of my files show up, and if I try to create a file it complains about needing elevated permissions. I've read online that I need to enable root access mode in File Manager's general settings, but there is no such setting on my device.

2

It turns out you have to enable "Superuser" mode in CM's settings app if it's disabled. I was only able to get to this setting by searching for it - I couldn't find it anywhere in the menu tree. Android normally restricts apps to only access their own special sub-folders on an attached flash drive, so File Manager needs special permissions to access everything.

0

I own a OnePlus One and, after plugging the USB Drive through OTG cable, use the ES File Explorer app which will save you from the hassle of permissions. In that app look under the Local tab to find your drive, usually called sdb. No need for root.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.