0

I couldn't get Google Calendar to sync on my Galaxy S3 (with web version of Google Calendar). I did all things recommended on this help page but it didn't help. I also tried removing Google account from the phone and adding it again.

However, during one of the reinstalls (as recommended in Google help page) I suddenly got a notification about an event in my calendar that was created in the web version. The sync worked perfectly fine when the Google Calendar App was removed from my phone. When "Google Calendar App" was uninstalled the pre-installed "S Planner" showed me the notification because the sync kicked in.

I rechecked it both ways from Android app to the web version and vice versa.

I prefer Google Calendar app to "S Planner" but this issue renders Google Calendar app unusable.

I also sent feedback message from the app.

Edit to add: it worked fine until one of the updates of Google Calendar.

Update: user RossC suggested to disable S Planner and test sync, but unfortunately I can't disable it (see screenshot). Disabling related applications (with words calendar, samsung and sync in the title) did not help.

S Planner app info. Cropped screenshot

full screenshot

  • Have you disabled SPlanner and tried it? Works fine here on an S3, S4 and S5 no bothers, once synch calendar is enabled in Accounts & Synch settings under your Google account. – RossC Feb 25 '15 at 12:10
  • @RossC Unfortunately, S Planner cannot be turned off without rooting, but app called "Samsung Calendar SyncAdapter" can be turned off. I will try that later, as I have to go right now. It's weird that everything else but the calendar (Contacts, e-mail) works fine. – andrybak Feb 25 '15 at 12:20
  • You can't uninstall it, but you CAN disable it. I've tried it on 3 samsung devices. Go to the app info and hit 'Disable'. It SHOULD work fine for you. I can only go on the devices I have here. That said, Samsung do some weird stuff with their bloatware so I wouldn't be surprised at all if you can't. – RossC Feb 25 '15 at 12:39
  • I can't disable it. The button "Turn off" is disabled. I added a screenshot in the post. PS Disabling related applications didn't help. – andrybak Feb 25 '15 at 13:22
  • This moves us back to Google calendar, but did you clear the cache? Select Calendar Storage. (If you don't see 'Calendar Storage,' press < Menu > again, then select Filter > All. On some devices, you won't see 'Calendar Storage.') Select Clear data. Answer OK when prompted. – LivedWithOtters Feb 25 '15 at 17:58
0

You could try and root your phone and download an app such as App Master from the app store to uninstall SPlanner altogether, as this would remove all of the Samsung calendar syncing issues you are having (hopefully - don't quote me but this worked for a friend of mine when he was having issues with his calendar syncing). Hope this is of some help :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.