24

I get a message

Android 5.0.1 System Update Available

but no option to skip the update.

In frustration, I click "download". It's not better after the download. I still get

System update downloaded

with no option to avoid the update.

How do I signal that I am perfectly content with KitKat 4.4.4 for the time being? I use my phone for development and want to be certain my development tools are ready before upgrading. In the meantime I also want to stop the continuous harassment via notifications. Is this possible? I am using a Nexus 5 and the phone is not rooted (I prefer it to stay that way).

  • As a pop-up or as something in the notification bar? What happens when you go to settings > apps > goggle services framework and turn off notifications? – LivedWithOtters Feb 26 '15 at 21:18
  • @LivedWithOtters Your suggestion did indeed stop the notifications briefly, but they soon resumed appearing (even though the notifications remain turned off for g.s.f.). The notification is permanently visible in the notification bar and also permanently visible in the notification screen (the double-swipe-down screen). – Calaf Feb 28 '15 at 15:41
  • @LivedWithOtters you were right in the direction, but instead it was Services not framework. – HasH_BrowN Nov 22 '15 at 18:59
24

I just spoke to Google directly. The Nexus 5 under settings, apps has something called Google Play services. Not store. If you uncheck the notification box in Google Play services and restart the phone the notification for the Android system updates will stop in the notification bar. Worked like a charm!

  • Please correct me if I'm wrong but it seems you must be rooted to do this. – steven smith Aug 11 '15 at 22:51
  • After updating to Lollipop 5.1.1, the notifications checkbox is rechecked for you. Thankfully, it's still there, and it does stop the new ongoing messages to update to 6.0. – Calaf Oct 29 '15 at 15:04
  • 2
    Worked fine on my Nexus 7 2012. Not rooted. – pelms Nov 2 '15 at 1:58
  • 1
    @stevensmith absolutely NOT. That is an option available in all apps that have notifications. – HasH_BrowN Nov 22 '15 at 18:56
  • 7
    You can long-press the update notification, then, click on the "i" icon, and you'll get to the same place to toggle block all. (No root needed. Tested on 6.0.1) – itsho Jan 13 '16 at 7:49
7

If you happen to be rooted, you should be able to install Disable Services and find the SystemUpdateService under Google Play Services disable Google Services Framework.

  • 2
    They moved the service under "Google Play Services". At least it's true for Android 6. – McTrafik May 9 '16 at 23:55
  • @McTrafik is right. On Android 6, go to Disable Services → Google Play Services → disable SystemUpdateService (and possibly SystemUpdateGcmTaskService too). – Mathias Bynens Mar 22 '17 at 15:00
  • Updated @MathiasBynens :) – Tristan Wiley Mar 22 '17 at 16:46
2

I figured it out :D :D

If you get the notification and have not yet downloaded the update. Simply Press the notification in the notification bar and Hold for 10 Seconds. It will give you two options. Click on the Settings button. From Settings select "Turn off notifications update" :)

2

You need to clear data for downloading application (DMClient)

  1. open system nofitication bar
  2. hold touch on system downloading bar until it pop up app info
  3. touch App info it will go to DMClient app info
  4. touch clear data button under Storage
  5. then touch OK for Delete app data question
0

Turning off auto updates in Google Store did not stop the phone updating, even after a reset. I pressed on an updating app until download manager appeared, then I disabled it. Seems to have stopped.

  • This sounds like a helpful suggestion, but I don't quite follow. Do you mean you long-pressed the notification to get the app info, and then disabled the download manager from there? If you can edit your question and explain a little further, it'll be more helpful. – Dan Hulme Jun 24 '16 at 12:12
0

Found it on Nexus Grand Prime: Settings - About Device (bottom) - Software Update (top) - Set 'check for updates' (Auto-Update) to Off.

The update wanted 530mb free space! Like hell, that space is reserved for game recording :).

0

On my LYF Flame 2 device in India, I tried Krystalblue's answer and could only limit the software update to "weekly", "wireless only" and disabled "Allow auto-update over WiFi...".
Hope that works!

0

Found option to disable automatic updates in developer menu on Android 7. (click many times on build number in about phone to enable that menu)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.