0

I just tried to connect my Nexus 5 to my Computer via USB but it does not show up anywhere. There is no sound of a device connecting and the Device Manager doesn't list a new device when I plug it in. MTP and USB Debugging are enabled. The cable I'm using it not the original one, but was advertised as a charger + data cable. I've tried connecting my device to both my PC and Laptop, but neither shows anything, but the device starts recharging as soon as I plug it in.

Anything I could've missed? Drivers? Settings?

Thanks in advance

  • Might well be the cable (being, other than advertized, a charger cable only). Have you tried a different cable? Even if you were missing the drivers, device manager would list it at least as "unknown device" otherwise. – Izzy Feb 27 '15 at 16:48
  • I don't have another cable lying around right now, but I'll try to get a hold of one. I suspected the cable being the problem, but I didn't want to contact the vendor yet (cable is 4 months old) in case I missed something. – Lukehey Feb 28 '15 at 12:57
  • To me, the cable is the most likely cause. I'd say take your device, cable, and laptop with you to a local vendor/shop, tell him your problem, and ask whether you might check with some of his cables. To be fair: in case one of those works, buy it from him if the price is OK. – Izzy Feb 28 '15 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.