0

Ok, there are dupplicates of this post. I've seen them, I've read them, and they didn't help. I could perfectly install apps until I tried to update SnapLock through their own app. Not enough space error. Ok. I deleted a couple of things, tried again. Nothing. More than 1 GB of free space on my internal storage and around 10 in my SD card. I uninstalled SnapLock and tried to reinsatall it through Google Play, it didn't work, I downloaded the .apk, it didn't work either. The worst is that the SnapLock apk file is like 10 MB the largst and I can download and install stuff 20MB large without any issues. I don't really know if I have to contact the app developpers for this, but still. Any help would be apreciated. EDIT: I can't install n7player either. I actually had it installed and tried to reinstall it, wich is kind of frustrating.

My phone is a Xperia M2 D2303 btw. Nico.

  • I have tried this app on my Xperia M and it is working fine. Maybe it is an issue with your device. – MANI Feb 28 '15 at 16:04
  • Well yeah it probably is, what I want to know is what issue it is, and how I can fix it. – NicoDC Mar 1 '15 at 19:23
0

as you may have noticed, this is not simple to solve. I had a similar issue with the facebook messenger and solved it deleting some files and folders. to use my method you will need root privilages, the "terminal emulator" app and a file manager that can access to your whole file system (like "root browser"). I also have the "busybox" app installed which might be necessary to use the terminal emulator properly.

the first thing I did was to spot all files associated to the app i coudn't install. in my case I achieved this in the terminal emulator with the commands

su 

find / -name "*[some part of the package name]*"

the first command is to gain root priviledges in the terminal in order for the find command to be able to search you whole file system. the second gives you a list of files and locations related to the app you want to install. the text in brackets [ ] must be replaced by a part of the name of package which diatinguishes from all others. in my case the package of the fb-messenger is called " com.facebook.orca-21.0.0.20.13.apk" so i decided to search this way:

find / -name "*orca*"

then I deleted all the files and directories listed using the root browser (this is a brutal force method, may be it is not needed to delete them all...).

finally I rebooted my phone let it start and installed the messenger through google play store. it worked :)

I hope this helps. I also spent some hours searching forums with no success.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.