0

I could perfectly install apps on my Xperia M2 (D2303) until I tried to update SnapLock through their own app. Not enough space error.

I deleted a couple of things, tried again. Nothing. More than 1 GB of free space on my internal storage and around 10 in my SD card. I uninstalled SnapLock and tried to reinstall it through Google Play, it didn't work. I downloaded the .apk, it didn't work either.

The worst is that the SnapLock APK file is like 10 MB the largest and I can download and install stuff that is 20MB large without any issues. I don't really know if I have to contact the app developers for this, but still.

Note that I can't install n7player either. I actually had it installed and tried to reinstall it, which is kind of frustrating.

There are duplicates of this post. I've seen them, I've read them, and they didn't help.

Any help would be appreciated.

2
  • I have tried this app on my Xperia M and it is working fine. Maybe it is an issue with your device.
    – MANI
    Feb 28, 2015 at 16:04
  • Well yeah it probably is, what I want to know is what issue it is, and how I can fix it.
    – NicoDC
    Mar 1, 2015 at 19:23

1 Answer 1

0

As you may have noticed, this is not simple to solve. I had a similar issue with Facebook Messenger and solved it by deleting some files and folders. To use my method, you will need root privileges, the "terminal emulator" app, and a file manager that can access your whole file system (like "root browser"). I also have the "busybox" app installed which might be necessary to use the terminal emulator properly.

The first thing I did was to spot all files associated with the app I couldn't install. in my case, I achieved this in the terminal emulator with the commands

su 
find / -name "*[some part of the package name]*"

The first command is to gain root privileges in the terminal in order for the find command to be able to search your whole file system. The second gives you a list of files and locations related to the app you want to install. The text in brackets [ ] must be replaced by a part of the name of the package which distinguishes it from all others. In my case, the package of the FB Messenger is called com.facebook.orca-21.0.0.20.13.apk, so I decided to search this way:

find / -name "*orca*"

Then I deleted all the files and directories listed using the root browser (this is a brutal force method, maybe it is not needed to delete them all...).

Finally, I rebooted my phone, let it start, installed Messenger through Google Play Store, and it worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .