Since I updated to Lollipop on my Moto G, I cannot access the internet when I am not logged into a Wi-Fi connection. Maps tells me that I'm offline, Chrome tells me that I am offline.

I go into Settings/Data usage and toggle the Cellular Data and Cellular Data Limit switches, same results. Toggle back to normal, same result. Restart phone, same result. Check settings for individual applications, nothing changes.

Any idea of something I'm missing?


that was weird. the day after I posted this, I dialed the magic 4636 number, changed nothing in the settings and the mobile data was working allright. I was confused.

Then today, it happened again. Mobile data was unavailable, there was a ! over the signal strenght icon. I ran the Ping test and I got this:

Ping IPAddr: Fail: IP Addr not reachable Ping hostname : Fail: Host unreachable HTTP Client test: FAIL : IOException. This also disabled the normal calling capability of the phone (see other post :error: call not sent. Unable to make outcalls?)

I turned the phone OFF and ON. It booted allright and now I has H+ and full mobile data usage.

So I thank you for the help, and I hope the workaround will be good enough to close the issue for now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.