0

I am experiencing a strange problem I just don't understand. Roughly a year ago I installed Cyanogenmod 10.2.1 (cm-10.2.1-endeavoru.zip) into my HTC One X. After that I have not been able to update to a newer Cyanogenmod (not manually, not through the update feature) or change into a completely new custom ROM. They just won't work.

Clockworkmod 6.0.4.8 is my recovery. I boot into it. Clear the essentials: factory reset, cache, dalvik (in this order). Then I install the ROM from sdcard and boot. No matter what OS ROM it is, it will ALWAYS get stuck during boot. If it's a different Cyanogenmod version, I get a grumpy android dude and an arrow rotating clockwise. If it's MIUI I get "MI mi.com". If it's AOSB I get their flashy animation and logo. Even if I let my phone sit on the table for an hour, nothing happens. It won't go forward.

After much frustration, I have to go back to recovery and install cm-10.2.1-endeavoru.zip using the method described earlier... AND IT WORKS! It doesn't get stuck and actually loads the OS.

What is going on? Why can't I change the operating system? Why is Cyanogenmod 10.2.1 the only one that works? Are there some cache files that I've missed or...?

Thanks.

  • A factory reset will wipe the caches, it ought to be sufficient. However, have you tried doing the factory reset after flashing the new ROM? – Matthew Read Mar 3 '15 at 15:51
  • I tried your suggestion, but unfortunately it didn't solve the problem. – user1567932 Mar 3 '15 at 20:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.