Please note that this question is now resolved (March 10, 2015) by new release of DE version 9.0.0.1 with thanks to Ryan.

My phone is Rooted and has BusyBox installed and USB Debugging enabled. Device Manager shows Android USB Devices \ My HTC - device working properly. DE shows blank 'Select Device' screen. I am running DE version 0.9.0.0 (x64) on Windows 7 Pro.

I have done the following..

  1. uninstalled all software that included a copy of adb.exe including Android sdk
  2. uninstalled DE
  3. uninstalled USB phone drivers
  4. re-booted the PC
  5. installed USB phone drivers by downloading and installing latest version of HTC Sync from the HTC web site.
  6. installed latest version of Android Studio
  7. installed DE
  8. copied android sdk (from the Android Studio installation) to c:\program Files\DE\Android\
  9. Updated the sdk path in the DE config file (in folder 'data') accordingly
  10. Run CMD.exe and, using the DE copy of adb.exe, killed the server, started the server, listed the devices; my phone was listed...... enter image description here

  11. Run DE and DE shows blank "Select Device" screen.... enter image description here

DE Config file....

<?xml version="1.0" encoding="utf-8" ?>
<DroidExplorer>
    <PluginSettings>
        <Paths>
            <Path>Plugins</Path>
        </Paths>
    </PluginSettings>
    <SdkPath>c:\Program Files\Droid Explorer\Android\sdk\</SdkPath>
    <Window>
        <Size>
            <Width>0</Width>
            <Height>0</Height>
        </Size>
        <Location>
            <X>0</X>
            <Y>0</Y>
        </Location>
        <FolderView>Details</FolderView>
    </Window>
    <ApkPaths>
        <Path>/data/app/</Path>
        <Path>/system/app/</Path>
        <Path>/data/app-private/</Path>
        <Path>/sd/app/</Path>
        <Path>/sd/app-private/</Path>
    </ApkPaths>
</DroidExplorer>

DE Log.....

2015-03-06 08:27:11,672   [1    ][ DEBUG] [DroidExplorer.Core.Logger] Settings Loaded from file 'C:\Users\Helen\AppData\Roaming\DroidExplorer\Data\DroidExplorer.config'
2015-03-06 08:27:11,720   [1    ][ DEBUG] [DroidExplorer.Core.Logger] Using build tools version 21.1.2
2015-03-06 08:27:11,721   [1    ][ DEBUG] [DroidExplorer.Core.Logger] Checking for adb.exe
2015-03-06 08:27:11,722   [1    ][ DEBUG] [DroidExplorer.Core.Logger] Using build tools version 21.1.2
2015-03-06 08:27:11,722   [1    ][ DEBUG] [DroidExplorer.Core.Logger] Checking for aapt.exe
2015-03-06 08:27:11,828   [1    ][ DEBUG] [DroidExplorer.Core.Logger] Using build tools version 21.1.2
2015-03-06 08:27:11,828   [1    ][ DEBUG] [DroidExplorer.Core.Logger] Checking for adb.exe
2015-03-06 08:27:11,828   [1    ][ DEBUG] [DroidExplorer.Core.Logger] adb.exe start-server
2015-03-06 08:27:12,093   [1    ][ DEBUG] [DroidExplorer.Core.Logger] 
2015-03-06 08:27:12,094   [1    ][ DEBUG] [DroidExplorer.Core.Logger] Using build tools version 21.1.2
2015-03-06 08:27:12,094   [1    ][ DEBUG] [DroidExplorer.Core.Logger] Checking for adb.exe
2015-03-06 08:27:12,094   [1    ][ DEBUG] [DroidExplorer.Core.Logger] adb.exe devices -l
2015-03-06 08:27:12,507   [1    ][ DEBUG] [DroidExplorer.Core.Logger] Using build tools version 21.1.2
2015-03-06 08:27:12,507   [1    ][ DEBUG] [DroidExplorer.Core.Logger] Checking for adb.exe
2015-03-06 08:27:12,507   [1    ][ DEBUG] [DroidExplorer.Core.Logger] adb.exe devices -l

On March 8, 2015.... enter image description here

I would appreciate receiving advice as to how to solve this problem.

Please note that this question is now resolved (March 10, 2015) by new release of DE version 9.0.0.1 with thanks to Ryan.

  • It looks like your adb is still an older version that is running. When you run adb devices -l it should list something like this: LGD85xxxxxxx device product:g3_tmo_us model:LG_D851 device:d851. Make sure you run the SDK manager after install, and get the latest version of the tools. Unable to locate SDK when starting Droid Explorer will help with that. What does adb version say? – Ryan Conrad Mar 6 '15 at 1:45
  • 1
    Welcome to Android Enthusiasts! It's good to know that your issue has been resolved. Instead of putting the note on the question, please accept the answer by clicking the 'tick' icon on the left of the answer :) – Andrew T. Mar 10 '15 at 1:14
up vote 2 down vote accepted

Part of the problem here had to do with Droid Explorer. There was a bug in version 0.9.0.0 that did not support when adb devices -l returned the "slimmer" format. This bug was corrected in 0.9.0.1.

I just had a breakthrough. The device is not responding correctly to the adb devices -l because the adbd that runs on the device, in this case the Incredible S, has not been updated to support the newer commands. The -l switch is a newer addition to the devices command. It only knows how to respond to adb devices, not adb devices -l, so it just ignores the -l and responds to the devices request as it normally would.

Since you have an SDK from when Droid Explorer used to install it here is what I suggest.

  • Uninstall Droid Explorer
  • Go into C:\Program Files\Droid Explorer\ and delete everything.
  • You can also delete C:\Users\Ryan\AppData\Roaming\DroidExplorer.
  • Open Registry Editor (WIN+R -> regedit -> ENTER)
  • Delete any of the following (if you don't have one or more that is ok, but delete all the ones you have)
    • HKEY_CURRENT_USER\Software\DroidExplorer
    • HKEY_CURRENT_USER\Software\Wow6432Node\DroidExplorer
    • HKEY_LOCAL_MACHINE\SOFTWARE\DroidExplorer
    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\DroidExplorer
  • Reinstall Droid Explorer
  • Make sure you pick the location of the Android SDK that you have installed

The SDKPath is no longer pulled from that config file. But I do actually have plans to put it back in the config file in the future.

The reason you have to uninstall is because we are deleting the registry settings, all of them. If you would like to try the Advanced Route, you can try the following:

Instead of deleting all the registry paths above check for one that contains InstallPath\SdkPath. This is probably in HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\DroidExplorer, but could be in one of the USER locations as well. Change the value of SdkPath to be your path to where you have the Android SDK installed.

  • my adb version is 1.0.32. FYI The SDK tools installer has the "run SDK Manager" check box checked and unless one unchecks that box, the SDK Manager runs as soon as the installer has completed. In any event I did run the SDK Manager again to ensure the latest updates were installed. – lahara Mar 7 '15 at 20:18
  • @lahara I have published the new version. Please clean up your comments here and if you have any further issues that relates to the bug that was discovered, we can discuss on the de.codeplex.com discussions. Hope this gets your device connecting. – Ryan Conrad Mar 9 '15 at 1:41
  • @lahara I added some information as to "why" if you are interested. see where I said "I just had a breakthrough". – Ryan Conrad Mar 11 '15 at 1:03
  • yes, I am interested so thanks for the info. Also - FYI because I have a production build ROM I am running "adbd insecure" on the phone then ADB ROOT before running DE which seems to handle the warning re DE not running in root. I will remove this comment in, say, 24 hours. – lahara Mar 11 '15 at 6:52
  • @lahara could you leave this comment. I think it is useful to the discussion. I only wanted to clean up comments before that were later addressed in the question or answer. I am interested in ADBD Insecure. I want to look in to that and see about maybe recommended that app to others when you get the warning message. – Ryan Conrad Mar 12 '15 at 0:52

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.