6

Is there a way to disable data roaming notifications?

I get them every few minutes when I'm working abroad. And it happens on every acceptable roaming setting (off/national), international roaming setting is no option.

Also, long press > App info (Phone app) > uncheck 'Show notifications' doesn't solve anything.

Android: 4.4.4 & 5.0
Phones: Sony Xperia Z1 compact and Z3 compact (but was also a problem on my previous phone on Android 4.1)

Screenshot with notification
Screenshot with notification (click image for larger variant)

Edit: This issue has solved itself as there's no extra charge anymore roaming within the EU.

  • Might be a carrier setting or app (like Sprint's Connection Optimiser). Some people seem to have been able to resolve it by accessing the carrier menu (##25327## or ##25327#) – Huey Jun 24 '15 at 6:30
  • Thanks for the advice. I'm with KPN in The Netherlands and the code doesn't work. But if it's something the carrier can resolve, I'll contact them and come back here with their answer. – Karel Jun 24 '15 at 7:38
  • I assume you are not using data, then? Have you tried toggling data off entirely? – Matthew Read Mar 22 '16 at 5:30
1

This was a big annoying factor for me and I eventually solved it, but it requires Xposed (which needs root).

If you have root and Xposed, you can install XphonePlus to disable the data warning and modify the phone's notifications for calls, mobile data and many more.

Not sure if there is an alternative without rooting.

0

Temporary solution:

  1. Change APN to anything out of thin air.
  2. Set phone to use it.
  3. Enable all data and roaming; national and international.

This solved my problem with annoying notifications. Don't forget to revert to normal APN after returning to original country.

  • That's a dangerous idea. I've heard of at least one carrier that reroutes your traffic from an invalid APN address to an APN for WAP with crazy prices. They dare to call it customer care. – wintermute May 24 '16 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.