0

As reported in an earlier post, I have rooted my HTC Desire Bravo with tacoroot and revolutionary, and my idea was to install a recovery ROM via the SD card.

The problem is that neither ClockworkMod nor TeamWin recovery image recognise my SD cards. I first had the cards (16G) partitioned into ~50% Fat32, ~50% ext{2,4} and about 100M swap. When that did not work I tried 100% Fat32, a much smaller Fat16 only partition and some other things, but the recovery images don't accept that an SD card is in there.

And that is essential for the 'install ZIP from SD card' feature.

Now the strange thing is that, from the shell prompt, I can do

adb push cm-11-20140921-UNOFFICIAL-bravo.zip /sdcard
adb push gapps-kk-20140105-signed.zip /sdcard
adb push Superuser-3.0.7-efghi-signed.zip /sdcard

to push CyanogenMod 11 (for the Bravo), the corresponding Google Apps, and Super User, onto the SD card while the recovery image is running and what is more, if I start a terminal (in TWR) and type ls /sdcard, then the files are listed there.

The SD card seems to be mountable, accessible, and usable by the recovery images, but so much so that it is treated as 'internal' storage, and that no extra SD card for installing ZIP files from can be found.

Has anyone seen such a thing before? And found a solution? Do other recovery images maybe install ZIPs from other places than only /sdcard?

The mount point /sdcard does correspond to the (micro) SD next to the SIM doesn't it?

  • To answer your last question: That depends whether they have one :) On my devices, it points to the internal SD cards. On some of them, when booted into "user mode", the external SD card is mounted inside that one (e.g. /sdcard/external_sd), on others in a different place – which again depends on the ROM used (e.g. my LG O4X had it inside /sdcard with stock ICS, but has it outside with stock JB). – Izzy Mar 3 '15 at 17:02
  • Ah right, that means that it genuinely does not mount. In the shell window inside TWR, the df and mount outputs don't show anything larger than 300M. Why that is I would still like to know! Most of my problems would be solved if the recoveries just allowed installing ZIP from /sdcard (so the internal SD) but they must have good reason not to (I guess it's the same place as where the new OS goes)? – alle_meije Mar 4 '15 at 7:57
  • No, it's not – OS goes to /system mostly (OK, parts might go to /boot, but no OS parts go to /sdcard as that's "user space"). If you have shell access when in recovery, you can try cat /proc/partitions to see all available partitions. The external SD card usually only has one partition, so it should be easily identified. Then you could umount /sdcard, and mount /dev/block/<partition> /sdcard – aftger that TWR should see the files stored there. Worth a try at least, doesn't break anything; if it doesn't work out, a simple reboot reverts it. – Izzy Mar 4 '15 at 9:52
  • Did that - but the names with the most blocks in the list -mtdblock4 and 5- are already-mounted partitions /system and /data. mtdblock0 .. 5 are accounted for and there are no others in /dev/block, only loop devices. – alle_meije Mar 5 '15 at 8:59
  • Can you put a listing (/proc/partitions) on some pastebin, and then meet me in chat? I'm always in our "main room" (Android Enthusiasts Chat). Just ping me there when you're ready (might take me a little to respond, as I'm on "other business" as well ;) – Izzy Mar 5 '15 at 9:28
0

Well, that one is solved!

The problem was not the SD cards, but the fact that rooting etc. the Desire caused it to USB-brick. Never heard that before. Some people can cure that with fastboot commands (did not work for me) but the 4ext recovery provides an USB un-bricking function.

Long story short, I'm running Spezi77's version of LiquidSmooth 3.2 on my Desire now after changing to 4ext! (following the advice on this link)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.