9

I have my Google Voice account setup through the Hangouts app for Android, on my un-rooted Galaxy S5 (with the Lollipop OTA).

When I have the application open on my device, and I receive an SMS to my GV number, it appears on screen.

If I don't have the application open, the phone still receives the message, but it does not give me a notification. I know background data is turned on, and it has received the message, because I can turn on airplane mode, then open the app, and see the message is there unread.

SMS messages sent to my carrier number as well as Actual Hangouts messages notify correctly whether the app is open on-screen or not.

Has anyone ever seen this before?

  • Are you sure you didn't disable the "Show notifications" option for Hangouts? Settings -> Apps -> Hangouts, right under Force Stop. – Chahk Mar 4 '15 at 14:48
  • Yes, I am sure. As I mentioned above, I still receive notifications for Hangout messages, as well as SMS messages, just not Google Voice SMS messages. – Nick Orlando Mar 4 '15 at 19:44
  • Just ruling out the low-hanging fruit first. Next on that list - in Hangouts app, in Settings -> [your Google account], under "Google Voice - [your GV number]" section make sure a setting "Messages (Show SMS & voicemail in Hangouts)" is selected. – Chahk Mar 4 '15 at 20:08
  • Yes, that setting is selected. – Nick Orlando Apr 22 '15 at 16:27
  • Do you have the actual Google Voice app installed? I remember reading some article a while ago saying that it's still needed. – Chahk Apr 22 '15 at 16:30
4
+150

It looks like there is an issue with Hangouts app that causes notifications for new conversations with a given contact to be disabled by default, with no way to override this setting. On the Conversations tab, these are denoted by a bell with a strike-through:
enter image description here
(click for larger image)

Once you open such a conversation you will see a message in red saying "Notifications off - You won't be notified of new messages" with an option to enable them:
enter image description here
(click for larger image)

Existing conversations for which you've enabled this setting will receive notifications normally. If you delete the conversation, the setting will revert to "off". Archiving the conversation keeps it enabled.

The details that are described in this thread (I suggest starring it to show Google that there is interest in this issue) match exactly what you are experiencing. It has been brought up before, and was escalated to the Hangouts development team, who are already aware of the issue. We can only guess when (or if) Google will fix this.

  • Well, in my instance, this looks like it is absolutely the issue that I'm having. I was able to reproduce the exact behavior you've described. What a frustrating bug. Thanks for finding this. – eldarerathis Apr 22 '15 at 17:54
4

I found this post on a google product forum and it worked for me. After you follow the steps, if it helps, I used the following service to send a test text message to my phone knowing it wouldn't be in my contacts and IT WORKED :)

https://www.clickatell.com/test-sms-gateway/

Tokiyo said: Found a solution trying to fix this problem. This will give you notifications of new messages from new numbers or new people on the Hangouts app.

  1. Go to your Hangouts app
  2. Menu
  3. Settings
  4. Your account email
  5. Customize invites
  6. Everyone Else
  7. Select "Can contact you directly"

Source: http://www.reddit.com/r/Android/comments/2vjtje/try_this_fix_if_your_hangouts_app_doesnt_notify/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.