I tried to root my new Samsung Galaxy S II today using the instructions in the CF-Root thread and in the videos provided by this guy on YouTube.

I was nearly across the finish line, but when I click the big "Root" button on SuperOneClick, it freezes at "Running psneuter" and won't go any further or shut down (without Task Manager intervention).

I've tried leaving it for > 10 mins, turning off all antivirus and I've tried 2 different SuperOneClick versions (1.9.1 and 1.7) to no avail.

Because of this, I'm pretty sure my root isn't going through properly. Mainly because when I check if my phone is rooted properly I can't get su access in shell.

Any ideas/thoughts about what to do?


According to an answer I got a thread I made at XDA Developers, it looks like the phone actually is rooted because the whole idea with the CF-Root Kernel I used is that it comes pre rooted (which makes me feel slightly sheepish!).

| improve this answer | |
  • Looks like someone patched the security vulnerability psneuter uses. :) – Broam Sep 16 '11 at 13:24

disable antivirus in your system before extracting superoneclick and while running it

| improve this answer | |
  • The OP specifically said he's already tried turning off his anti-virus software. Besides, this question already has an accepted answer: the phone was already rooted. – Dan Hulme Sep 20 '13 at 14:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.