1

When I start google play store I get a white page with the message "Server error" and a "retry" button.

logcat tells me:

03-07 11:31:29.148: E/Volley(7984): [13] BasicNetwork.performRequest: Unexpected response code 400 for https://android.clients.google.com/vending/api/ApiRequest  
03-07 11:31:29.156: D/Finsky(7984): [1] 2.onErrorResponse: Metadata failed: com.android.volley.ServerError  

But the internet browser and youtube both work fine.

I found the advice to remove my google account and recreate it. It doesn't let me remove it because it says the account is used and I should do a factory reset instead. Of course, all my data would be cleared.

I cannot install any backup app because play store doesn't work. So no factory reset for now.

I tried to create a new google account but it fails. It waits a while with the message "Your phone needs to communicate with Google servers to set up your account. This may take up to five minutes.", then "Can't establish a reliable data connection to the server.".

I tried to clear the data of Google Play Store and Google Services Framework and power the device off and on.

Is it some known problem? Anything else I can try?

I am on Android 2.3.6, Play Store displays build 3.4.7

PS: while checking the build version, Play Store crashed unexpectedly. Probably because of previous errors.

0

When I randomly get server errors from Google Play, I usually resolve by removing /etc/hosts file (a rooted phone and an ap like Root Explorer is needed). Sometimes I have to reboot the phone, sometimes it works straight away.

Tip: To be sure avoiding system breaks and soft bricks (for how unlikely it is doing this operation), instead of removing the file rename it to something else, so that you can restore it back if needed.

  • Thanks. But in my case it is not random, it is systematic. And I looked at my /etc/hosts it only contains the 127.0.0.1 localhost line. – Florian F Mar 7 '15 at 14:29
  • Random I mean they randomly occur, it may trigger tomorrow or the next month, but when they do they stay until solved. My hosts file contained only two lines like this, but still it did the trick. – Jeffrey Lebowski Mar 7 '15 at 14:43
  • I did. I had to remount the file system to read-write before that. I renamed hosts to hosts.old and rebooted. No difference. – Florian F Mar 7 '15 at 15:42
  • Change /etc/hosts content to what?! – Dr.jacky Feb 14 '16 at 11:15
  • To nothing. The solution I proposed consists in completely deleting the file. It did not work for the OP, anyway. – Jeffrey Lebowski Feb 14 '16 at 15:56

protected by Community Oct 19 '15 at 2:33

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.